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Micro Focus Academic Program 2.3 Update
2 - Release Notes

These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.

Overview

The Micro Focus Academic Program brings contemporary software development tools and technologies to
COBOL development helping to bridge the gap between the old and the new.

COBOL applications still run many of the world’s business systems, therefore teaching the COBOL
language is a great way to prepare your university's students for a robust IT career in today’s economy.

The Micro Focus Academic Program is designed to support the education and use of the COBOL language
within the academic setting. This program supports our academic partner community through the use of
our COBOL development tools and materials within the classroom.

This program will enable your university to quickly join this growing league of similar academic
organizations in support of the promotion and education of the COBOL language.

Welcome! We're excited to have you join our growing academic community.

Product Description

The Micro Focus Academic Program Edition package comprises the following products:

« Visual COBOL - delivers the richest development experience for COBOL programming. On Windows,
Visual COBOL is available for use with Microsoft's Visual Studio or with the Eclipse integrated
development environments. On UNIX or Linux, it is available for use with Eclipse. Visual COBOL
supports the development and deployment of both JVM COBOL and .NET COBOL, and of native
COBOL applications.

Variants of Visual COBOL include:

* Visual COBOL for Visual Studio 2012, Visual Studio 2013 or Visual Studio 2015
« Visual COBOL for Eclipse (Windows)

« Enterprise Developer - a contemporary development suite for Microsoft Visual Studio or for Eclipse that
enables mainframe developers to maintain, develop and modernize mainframe applications regardless
of whether these are to be deployed back on the mainframe or onto an alternative platform. Enterprise
Developer supports IBM COBOL, IBM PL/I, IBM Assembler, IBM CICS, IBM IMS, IBM JCL, IBM DB2,
IBM z/OS file formats and common batch utilities including SORT. This means you can develop and
maintain the core mainframe online and batch applications under Enterprise Developer, then deploy
them back on the mainframe or migrate them onto one of the Micro Focus production platforms
available on UNIX, Linux, or Windows. Variants include:

« Enterprise Developer for Visual Studio 2012, Visual Studio 2013 or Visual Studio 2015
« Enterprise Developer for Eclipse

Micro Focus Academic Program differs from the full version of these products in a number of ways. The
differences are:

* You cannot deploy applications on other machines, so Micro Focus COBOL Server and Enterprise
Server are not supplied.

« An authorization code for the Micro Focus Rumba 3270 terminal emulator is not supplied.
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Note: Micro Focus Academic Program is supplied for Academic use only. It is not to be used for any
commercial purposes. You must be a registered Micro Focus Academic Program Partner in order to
use this software.

For more information, follow the link in the Electronic Product Delivery email for the End User License
Agreement.

Reporting Issues

* For the latest information and discussions on this product, or to report issues, visit the Micro Focus
Community Web site.

f Note:

» This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link.
Web sites by their nature can change very rapidly and although we try to keep our links up-to-date,
we cannot guarantee that they will always work as expected.

e Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro
Focus Infocenter for any updates to the documentation which might have been uploaded.

Significant Changes in Behavior or Usage

This section describes significant changes in behavior or usage. These changes could potentially affect the
behavior of existing applications or impact the way the tools are used.

Where present, the numbers that follow each issue are the Support Incident Numbers followed by the
Reported Problem Incident (RPI) number (in parentheses).

e AppMaster Builder

* Enterprise Server

e Compiler

« Eclipse IDE

e MF Directory Server

* Monitoring and Management
e PL/I Support

¢ Run-Time System

AppMaster Builder
Back to the list

« To correct a problem with generating programs when no APRPROG member is present, a new Output
Generation preference has been added that, when enabled, creates a temporary APSPROG member at
generation time if none is found. In addition, a new customizable APRPROG template is available to
enable customization of the temporary APSPROG member.

2849347 (1103014)

Compiler
Back to the list

« The ILPINVOKE directive is now allowed only in an initial $SET. This is in line with similar directives like
ILREF and ILTARGET. Previously, the ILPINVOKE directive was allowed in other positions in the source
code, but could later result in 'Insufficient memory' errors.

2860347 (1104422)
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* Replacing a partial token no longer causes the second part of the token to appear on a new line. This
could happen if the new text was larger than the text being replaced.

2869185 (1105763)

* There is no longer a problem opening an RM/COBOL indexed file when the program has a RECORD
CONTAINS n CHARACTERS clause and there are record descriptions with lengths less than n. This
situation previously caused a 39 error on the OPEN (other than OPEN OUTPUT) because there was a
mismatch in the minimum record length.

Eclipse IDE
Back to the list

« This update modifies any existing connections defined in an Eclipse workspace. If the connections had
any non-default values, those values could revert to their original default setting. After installing this
release, before you use any remote connections for the first time, you need to check the settings and
amend them as necessary.

2852872 (1103699)

Enterprise Server
Back to the list

< Previously, it was possible to install groups that should not have been installed. If a group name, as
defined in the Startup List, did not exist in the list of Groups then the next Group in the alphabetical
order would be loaded instead. Now, if a Group is not defined in the list of Groups, a warning that the
Group could not be loaded is issued.

2869848 (619107)

MF Directory Server
Back to the list

« The "-n" option for the mfds command now supports hostnames as the network addresses in addition to
IPv4 addresses.

2816871 (1099564)

Monitoring and Management
Back to the list

* Messages that are written to the console log by applications that perform "display upon console" now
contain a standard message ID (CASMGO0001I).

2854207 (1103659)

PL/I Support
Back to the list

e A problem with PUT STRING when compiled with the -bigendian option in effect has been fixed. Note
that when upgrading to ED 2.3 U2 you must recompile any program using PUT SPRING.

2857374 (1104039)

« Previously, if using the -incafter option of the macro preprocessor to infuse a %INCLUDE with macro
logic, you were required to schedule a second macro pass to preprocess the contents of the
%INCLUDE. This is no longer necessary and the macro logic will be preprocessed on the first macro
pass as if it was part of the original source.
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* Previously, if writing output to a CTLASA (PRINT) file with the optional LINE(x) parameter having a
value of x that was less than the current line, PL/I did not generate ASA Control characters to end of
page and emit the output on the first line of the new page. This no longer occurs.

2871278 (1106114)

* Previously, if SIGPIPE was triggered when a PL/I program was in the callstack, then PL/I error handling
got control and processed the ERROR. This no longer occurs. Users who rely upon catching SIGPIPE
can re-enable it by adding a call to cobpostsighandler() to their code to turn it back on.

2859980 (1104399)

Run-Time System
Back to the list

« The command_line_linkage tunable has been deprecated; equivalent functionality can be achieved by
using the COMMAND-LINE-LINKAGE Compiler directive instead.

2838118 (1101539)

Known Issues

Refer to the Known Issues and Restrictions topic in the Product Information section of your product Help.

In addition, note the following:

Application Workflow Manager

* In an Application Workflow Manager modelled action, you retrieve a file from the remote zOS system
directly into a COBOL project, you must set the text file encoding of the COBOL project to UTF-8 in the
project properties in order for the Compiler to correctly process the source code. To set the encoding, in
the project properties of the COBOL project and on the Micro Focus > Project Settings > COBOL,
specify the sour ce- encodi ng( ut f 8) Compiler directive in the Additional directives field.

« In some situations, when you start Visual COBOL for the first time from a new workspace, you might
receive the following error message: "'System Loader' has encountered a problem. TSCOR0149 Failed
to load AWM systems." You can ignore this message as this has no impact on the product and on your
applications.

Debugging

*  When debugging a remote program, the performance of the network, specifically the latency between
the local and remote machines, will have an effect on the responsiveness of Eclipse. Whenever Eclipse
has to show the new execution position, a number of messages are sent from the remote machine, over
the network, to get the required information. The effect of this is that it can take a few seconds after a
Step command is issued before Eclipse has updated the screen and is ready for the next command.

You can mitigate this delay by closing any unnecessary debug views. For instance, by closing the
Expressions view and the Variables view, the number of messages that are sent is reduced, which
allows Eclipse to update quicker.

« Large programs can suffer from a large delay the first time that the program is displayed in the debugger
and an expression is evaluated. You can reduce this delay by following these steps:

1. Create atext file called debugconfi g. xm .
2. Add the following lines, and then save the file:

<?xm version="1.0" encodi ng="utf-8" ?>
<Nat i veDebugger Opt i ons>

<DebugOpti on Opti on="REMOTECHECKER' Val ue="yes"/>
</ Nat i veDebugger Opt i ons>

Micro Focus Academic Program 2.3 Update 2 - Release Notes

7



8

3. At a command or shell prompt, set the environment variable DEBUG_CONFIG to the full path name
for debugconfi g. xm .

4. Start Eclipse from the same command or shell prompt.

« Remote debugging does not work for programs running on AIX or HP machines, if you are trying to
debug using Visual COBOL installed on a Linux machine.

Database Access

« If you have a remote COBOL project under Eclipse that uses DB2 ECM in Visual COBOL or HCO for
DB2 LUW in Enterprise Developer and the DB2 software is not installed on the client machine where
you are using the Eclipse IDE, you receive background parsing errors in your application. To resolve the
issue, you can do either one of the following:

« Disable background parsing Window > Preferences > Micro Focus > COBOL > Editor and
disabling the checkbox for Background parsing.

« Install the IBM DB2 client-side software on the machine on which you are running Eclipse. Go to the
IBM Support Home and locate the page entitled "IBM Download Fix Packs for IBM Data Server
Client Packages" .

Enterprise Server

e The Historical Statistics Facility may generate incorrect records for SSTM-enabled enterprise servers.

« On Windows 10, if you are using Microsoft's EDGE browser to access the Enterprise Server
Administration GUI, issues with EDGE can cause the automatic refresh feature to display a dialog
asking whether you want to resubmit a form. To work around this issue, cancel the resubmit request and
then refresh the server list page or the Home page of Enterprise Server Administration. You can also
turn off the automatic refresh by setting the Auto-refresh interval setting on the Home page of
Enterprise Server Administration to O.

e In Visual COBOL 2.3, some job scheduling tools from third-party vendors might stop communicating
with Enterprise Server. This might have an impact on our external partners who integrate with
Enterprise Server such as job schedulers which do not use MFBSI. The issue might occur with job
schedulers such as Zena, CA, ASG or UC4, if these are run outside of a COBOL environment with the
path set. Click here for more information about the issue and how to work around it.

IDE

» If you are upgrading your license from Visual COBOL for Eclipse Personal Edition (v2.2 or earlier) to
Visual COBOL, or from Visual COBOL Connect (v2.2.1 or later) to Visual COBOL, any existing projects
compiled to either .exe or .dll files using the old license must be updated in order to recreate
the . cobol Bui | d file. You can do this done by adding or removing files from the project or by deleting
the . cobol Bui | d file. Updating the project in this way ensures Eclipse will fully build the executable
files.

« When you add a COPY statement in a COBOL program and then show it in Expanded Copybook View,
the line for the copybook statement is read-only. If you then perform an Undo in the COBOL program,
the COPY statement is removed while the contents of the copybook is still shown in the program.

* Replace All does not work inside the Expanded Copybook View

« For copybooks with file extensions that are not traditionally associated with COBOL you must first add
the file extension to the list of known copybooks extensions in Tools > Options > Text Editor > File
Extensions before you can show them in Expanded Copybook View.

Linking

e Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C
object code built with that version of Visual Studio in the same executable. In this scenario, you must
use the Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro
Focus cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might

Micro Focus Academic Program 2.3 Update 2 - Release Notes
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also need to specify some additional C runtime libraries - see the Microsoft documentation for more
details.

Note that when using COBOL and C object code together, Micro Focus recommends you build and
keep the COBOL and C executables separate, and use import libraries and the Micro Focus C functions
for calling COBOL (see "C functions for calling COBOL" in the product help) to resolve calls between
them.

Micro Focus Rumba

« On versions of Windows Vista and later, Enterprise Server listens only on the IPv4 loopback address
(127.0.0.1). As a result, an attempt to connect to localhost with a TN3270 emulator such as Micro Focus
Rumba may fail. To work around this issue, in your emulator's configuration use 127.0.0.1 in preference
to localhost or your host machine's name.

PL/I Support

« The Micro Focus PL/I Macro Preprocessor supports the majority of the IBM PP(MACRO) functions. The
only support for PP(PLX) is for the deprecated KEYS option. There are no plans to further extend the
existing support for PLX.

« Trying to debug remote PL/I projects that compile to 32-bit using the CodeWatch debugger fails. To work
around this issue, you must set the environment variable $COBMODE to COBMODE=32 on the remote
machine before you start the RDO daemon.

Resource Adapters

« Trying to deploy the local resource adaptor nf cobol - | ocal t x. r ar to WebLogic may fail with a
ClassCastException. To work around this issue, you need to deploy nf cobol - xa. r ar first, then need
to undeploy this file and deploy the local one, nf cobol -1 ocal t x. r ar . If there are issues deploying
using the WebLogic GUI, you can use the command line. If there are issues with this as well, try
reducing the length of the command (for example, by moving the file to a location with a shorter path).

REST/JSON IMTK implementation and the same-origin policy (SOP)

« HTTP requests sent from scripts within a web browser to REST services deployed on an enterprise
server might fail due to the same-origin policy (SOP). Some browsers might implement (or support
plugins that implement) techniques for relaxing SOP such as cross-origin resource sharing (CORS) that
enable sending cross-origin requests successfully. For REST services, Enterprise Server does not
implement a method for relaxing SOP. This means that browsers that implement CORS (or any other
SOP relaxation technique) might still forbid requests made from scripts due to Enterprise Server not
implementing the equivalent technique on the server side.

Viewing the Product Help

e Aknown issue in JRE 1.7.0_45 (issue JDK-8028111) causes problems with searching and indexing the
help in the Eclipse help viewer if you are running Eclipse on a machine that has this version of JRE
installed.

z/Server

e |IBM's PTF UA75804 causes ISPF dialogs in a user server to stop working. If you have this PTF
installed, contact Micro Focus SupportLine to obtain a fix for this issue.

-2814867 (1098663)

Installation

Micro Focus Academic Program 2.3 Update 2 - Release Notes | 9
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System Requirements

Hardware Requirements

In general, most modern machines will have the required processor and available RAM to run the Micro
Focus products under Windows effectively. For planning purposes, you should consider having a minimum
of 2GB of RAM though Micro Focus recommends at least 4GB of RAM for optimal performance.

Visual COBOL and Enterprise Developer for Visual Studio

Visual COBOL and Enterprise Developer have the following requirements in addition to the requirements of
Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.

The disk space requirements are:

Product Maximum Disk Space Sentinel RMS License Manager
Requirements

Visual COBOL 1.2GB 75MB
Enterprise DeveloperEnterprise 2.3GB 75MB
Developer

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Visual COBOL and Enterprise Developer for Eclipse on Windows

The disk space requirements are:

Product Maximum Disk Space Sentinel RMS License Manager
Requirements

Visual COBOL 3.7GB 75MB
Enterprise Developer 4.5GB 75MB

Note: This includes the space needed to cache information locally so that you can modify the
installation without the original source media.

Operating Systems Supported

Note: If you are using Visual COBOL or Enterprise Developer on a 64-bit operating system, you can
produce either 32-bit or 64-bit applications.

For a list of the operating systems each individual product in this package supports, check the Product
Availability section on the Micro Focus SupportLine Web site: http://supportline.microfocus.com/
prodavail.aspx.

* Visual COBOL for Visual Studio is not supported on versions of Windows earlier than Windows 7.

Software Requirements
/ Note: This product includes OpenSSL version 1.0.1p.

Windows

Note: The setup file will check your machine for whether the prerequisite software is installed and will
install any missing prerequisites and the product components.

Micro Focus Academic Program 2.3 Update 2 - Release Notes
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Visual COBOL and Enterprise Developer for Visual Studio:

This pro

duct requires Microsoft's Visual Studio - either the Visual Studio Integrated Shell or a more

advanced version of Visual Studio.

The following advanced editions of Visual Studio are required:

Professional, Premium, or Ultimate (for Visual Studio 2012)
Professional, Premium, Ultimate or Community Edition (for Visual Studio 2013)
Professional, Enterprise or Community Edition (for Visual Studio 2015)

If there i
2012 or

/e

s no Visual Studio installed on your machine, the setup file for Visual COBOL for Visual Studio
2013 will install the Visual Studio Integrated Shell.

/. Important:

A problem with Microsoft's Windows 10 prevents installing the Visual Studio 2013 Shell on that
version of the OS. You must install an advanced edition of Visual Studio 2013 on Windows 10
before you start the installation of Visual COBOL for Visual Studio 2013.

Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as part of .NET
Framework version 4.6 can result in incorrect execution of some COBOL code compiled to .NET.
Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and
Microsoft's Windows 10. The problems include incorrect execution of MOVE and STRING
statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase
for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications compiled
to .NET and some can be reproduced in other languages (C# or Visual Basic).

These problems have been reported and acknowledged by Microsoft and it is our belief that they
either have resolutions or are working on fixes for all of them. For further information about these
issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see RyuJIT
Bug Advisory and Troubleshooting RyuJIT.

As of October 2015, Microsoft have released the following updates that address these issues with
the .NET Framework 4.6:

» Hotfix rollup 3088955 for the .NET Framework 4.6 on Windows Server 2012 and Windows 8 -
see: http://www.microfocus.com/docs/links.asp?vc=mskb3088955.

» Hotfix rollup 3088956 for the .NET Framework 4.6 on Windows Server 2012 R2 and Windows
8.1 - see: http://www.microfocus.com/docs/links.asp?vc=mskb3088956

» Hotfix rollup 3088957 for the .NET Framework 4.6 on Windows 7 SP1, Windows Server 2008
SP2, Windows Server 2008 R2 SP1, and Windows Vista SP2 - see: http://
www.microfocus.com/docs/links.asp?vc=mskb3088957.

e Cumulative update 3093266 for Windows 10: September 30, 2015 (available through Windows
Update) - see: http://www.microfocus.com/docs/links.asp?vc=mskb3093266.

Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a
number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the
setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that
there is an advanced edition of Visual Studio 2015 installed on your machine.

te:

On Windows 8.1 RT, Windows 8.1 or Windows Server 2012 R2, you must have the Windows
update KB 2919355 before you install Visual Studio 2015. Download KB 2919355 from the
Microsoft Download Center.

Microsoft Visual Studio Express Edition is not supported.

Micro Focus Academic Program 2.3 Update 2 - Release Notes | 11
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* You can download the Visual Studio Integrated Shell from the Microsoft Download Center. If you
choose to install the Shell, ensure you run the installer to complete the installation - run
vsi nt shel I . enu. exe from the location where you installed the download.

Note that some Visual Studio features might not be available with the Shell. This includes WCF or
the Visual Studio 2013 Connected IDE experience in the Visual Studio 2013 Shell - the help for
more details.

The following software is also required:

* Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft
Download Center and search for Windows SDK.

* Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.
* Microsoft .NET Framework 4.5.1. This is included with Visual Studio 2013.
* Microsoft .NET Framework 4.6. This is included with Visual Studio 2015.

Visual COBOL and Enterprise Developer for Eclipse:
The following requirements apply to both Visual COBOL and Enterprise Developer:
» The setup file installs Visual COBOL and Eclipse 4.4.2.

See Installing Visual COBOL into other instances of Eclipse for instructions on how to install Visual
COBOL into other instances of Eclipse installed on your machine.

Note: If you are installing Visual COBOL into Eclipse 4.5, you must install the Eclipse Target
Management plugins into the Eclipse IDE for Java EE Developers package (32-bit):

1. Click Help > Install New Software in your Eclipse 4.5 and add a new repository for the location
htt p: // downl oad. ecl i pse. org/ t m updat es/ 4. 0.

2. Expand RSE 3.8 Main Features, check RSE Terminals Ul (Deprecated) and complete the
installation of the plugin.

* Visual COBOL does not support the 64-bit Eclipse. You can, however, use the 32-bit Eclipse to create
both 32-bit and 64-bit applications.

« Visual COBOL requires a 32-bit Java installation.

The setup file will check your machine for whether the prerequisite software is installed and will install any
missing prerequisites and the product components.

* Oracle's Java Platform, Enterprise Edition (Java EE) Java 7 or Java 8 is required to execute COBOL
JVM code and for native COBOL and Java interoperability. You can download Oracle's Java EE from
Oracle's web site and install it anywhere on your machine.

Note: If Java 7 is installed on your machine, to skip installing Java 8, run the Setup file with the
ski pj r e=1 command line option.

e The setup file also installs .NET Framework v4.5.2 and the Microsoft Visual C++ 2010 and 2012
Redistributables.

Installation Restrictions and Requirements

Before starting the installation you should be aware of the following:

« Visual COBOL and COBOL Server cannot coexist on the same machine.

« Visual COBOL and Enterprise Developer cannot coexist on the same machine regardless of which IDE
(Visual Studio or Eclipse) you install.

< If, when you install Visual COBOL for Visual Studio , the machine does not have Microsoft Visual C++
Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of
Microsoft Visual C++ Redistributable Runtime adds a number of . dl | files, without digital signatures,
into the wi nsxs directory.

Micro Focus Academic Program 2.3 Update 2 - Release Notes
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« If, when you install Visual COBOL for Visual Studio 2013, the machine does not have Microsoft Visual C
++ 2012 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ Redistributable Runtime adds a number of . dl | files, without digital
signatures, into the wi nsxs directory.

« You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.

« If you are installing this as an upgrade, make sure that none of the product files are in use when you
start the installation. Also, the Visual Studio Help Viewer must not be opened.

* You need to be logged in with a user-1D that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.

» Before installing this product , make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows service (on Windows) from an existing product is stopped and uninstalled. On
Windows, do this as follows:

1. Stop the service, using either the Windows Service Management Console GUI or from a command
line prompt by typing: net stop nf_ccitcp2 Only one instance of the MFDS or CCITCP2
service can run on a Windows machine.

2. Uninstall the MFDS or CCITCP2 service.

For MFDS, from a command line prompt enter: nfds -u
For CCITCP2: ccitcp2 -u
To run an earlier version of MFDS as a service after you have installed a later version:

1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:

a. Open a Visual COBOL command prompt.
b. Install the service. Enter the following command: nf ds -
c. Start the service. Enter the following command: net start nf_ccitcp2

Note: The two versions use different paths for environment and registry values, so the list of
configured Enterprise Servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.

MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.

It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Downloading the Products

1. Use the download links in your Electronic Product Delivery email.

For more information follow the links for the installation instructions and the End User License
Agreement.

Installing the Products

Use the individual setup files to install each product from the Micro Focus Academic Program package as
follows:

Micro Focus Academic Program 2.3 Update 2 - Release Notes
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Windows

1. Run the pr oduct namne. exe file and follow the wizard instructions to complete the installation.

After Installing

Visual COBOL and Enterprise Developer for Visual Studio

You are now ready to run Visual COBOL or Enterprise Developer. From the Windows taskbar click Start >
All Programs > Micro Focus Product Name > Product Name for Visual Studio. (The Start menu is not
available on Windows 8, Windows 8.1, and Windows Server 2012. You use the Start screen to invoke
programs.)

Refer to the Start Here and Product Information sections in your product Help. Here, you will find
information on getting started including tutorials and demonstration programs.

» To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to local
help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help Browser.

Visual COBOL and Enterprise Developer for Eclipse

If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the perspective you
are working with after installation:

1. Open the existing workspace with this product.

You may receive some warnings or errors which you can ignore.

2. Make sure you are in the perspective you need to reset by clicking Window > Open Perspective >
Other.

From the Open Perspective dialog box, click the perspective you want to reset.
Click OK.

Click Window > Reset Perspective.

When prompted, click Yes.

Reapply any customizations.

No ok ow

Installing X Windows on Windows

Some features of Visual COBOL for Eclipse and Enterprise Developer for Eclipse on Windows require an X
Windows installation, so Micro Focus ViewNowX is provided with the product. To install, run the file

Vi ewNow_X_Ser ver . exe in your Visual COBOL installation. By default this will be in the

%°r ogr anti | es(x86) % M cro Focus\ Vi sual COBCL for Visual Studio 2012\ Vi ewNowX
folder.

ViewNowX requires that your client machine has Microsoft Visual C++ 2008 SP1 Redistributable Package
(x86) installed. If it is missing from your machine, the ViewNowX installation will offer a link to download the
package.

Repairing

Windows

If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the Control Panel, click Uninstall a program under Programs.
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2. Right-click your Micro Focus product and select Repair.

UNIX

If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.

Uninstalling

Windows
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs in Control Panel.
3. Select the product and click Remove or Uninstall as appropriate.

When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.

Note: The installer creates separate installations for Visual COBOL, Enterprise Developer, Enterprise
Server for .NET, and Micro Focus License Administration. Uninstalling only Visual COBOL does not
automatically uninstall Enterprise Server for .NET, the Micro Focus License Manager or any of the
prerequisite software.

Enterprise Server for .NET must be uninstalled before you remove Visual COBOL. To completely
remove the product you must uninstall the Micro Focus License Manager as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Some registry entries are not removed by the uninstallation process and you need to manually delete
them.

The following folders might not be removed:

e Mcro Focus Product Name folderin the Start menu - you can delete it manually.

e OUsystendrive% Users\ Public\Docunents\M cro Focus - includes the binaries and the log
files of the samples which you have built.

* 9%°rogranDat a% M cro Focus - includes some data files used by the Micro Focus licensing system.

e 9%rogram Fil es% M cro Focus - you can delete it manually.

Disclaimer

This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fithess for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.

Micro Focus is a registered trademark.
Copyright © Micro Focus 1984-2016. All rights reserved.
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