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1
 Managing Tags
You use a simple tagging language to identify workspace objects as members of 
higher-level functional, structural, or other types of groupings. After you set up 
these groupings, you can chart them in Enterprise View or “black-box” them in 
the Diagrammer. 

Each member of the higher-level grouping is identified by a tag: Customer 
Maintenance, for example. Each grouping can, in turn, reference a more inclu-
sive grouping: Application Functions, for example. Later, when you generate 
charts or diagrams, the tags determine what the chart measures or the diagram 
“black boxes.” The figure below shows a typical tag structure. 
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MANAGING TAGS
UNDERSTANDING THE TAG MANAGER WINDOW
Understanding the Tag Manager Window

Describes the Tag Manager window.

Use the Tag Manager to create and assign tags to objects, and create relation-
ships between tags. To open the Tag Manager, choose Analyze > Tag Manager. 

The figure below shows the Tag Manager window. The Objects List pane shows 
repository objects and their tags. Your selections in the other Tag Manager 
panes filter the objects displayed in the Objects List pane. 

By default, all Tag Manager panes are displayed. Select the appropriate choice 
in the View menu to hide a pane. Select the choice again to show the pane. 
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MANAGING TAGS
UNDERSTANDING THE TAG MANAGER WINDOW
Object List Pane

Describes the Object List pane.

The Object List pane displays workspace objects filtered by your selections in 
the Category, Project, Object Types, Search, and/or Query panes; or by your 
selections in the Tags pane.

By default, the Object List pane displays up to 100 repository objects and their 
tags. Click the  button next to the  icon on the toolbar and choose:

• More Objects in the drop-down menu to display the next 100 objects that 
match the filter criteria.

• All Objects in the drop-down menu to display all the objects that match 
the filter criteria.

Category Pane

Describes the Category pane.

The Category pane displays the categories you can use to filter objects in the 
Object List pane:

• All Objects comprises source and generated objects in the workspace.

• Generated Objects comprises generated objects in the workspace.

• Legacy Objects comprises source objects in the workspace.

Projects Pane

Describes the Projects pane.

The Projects pane displays the workspace projects you can use to filter objects 
in the Object List pane. Entire Workspace comprises all the projects in the 
workspace.

Object Types Pane

Describes the Object Types pane.

The Object Types pane displays the objects types you can use to filter objects in 
the Object List pane. 
3



MANAGING TAGS
CREATING TAGS
Search Pane

Describes the Search pane.

The Search pane lets you filter the objects in the Object List pane using wildcard 
patterns allowed in LIKE statements by Visual Basic for Applications (VBA). 
Enter the pattern in the Object Name field. The Object List pane is refreshed as 
you type. 

NOTE:  In large repositories, the Object List pane may not immediately refresh as 
you type. Press the Enter key to instantly display matching objects for the current 
string.

Query Pane

Describes the Query pane.

The Query pane lets you filter the objects in the Object List pane using complex 
queries. Select a query to filter the Object List by its terms. Select another query 
and choose:

• Add Tags > with <And> in the right-click menu to AND its results with 
the results of previous queries.

• Add Tags > with <Or> in the right-click menu to OR its results with the 
results of previous queries.

Tags Pane

Describes the Tags pane.

The Tags pane lists the tags in the workspace. Select one or more tags to display 
the objects assigned the tags in the Object List pane. 

Creating Tags

Describes how to create tags.

To create a tag, choose Edit > Create in the Tag Manager window. A dialog box 
prompts you to enter the name of the new tag. Enter the name and click OK. 
The tag is displayed in the Tags pane.
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MANAGING TAGS
SPECIFYING ACCESS TO TAGS
Specifying Access to Tags

Describes how to specify access rights to tags.

By default, the tags you create are public. To make a tag private, that is, visible 
only to you, select it and choose Set Access > Private in the right-click menu. 
To make the tag public again, choose Set Access > Public in the right-click 
menu.

NOTE:  Tags shipped with the workbench are always public. You cannot change 
their access. 

Assigning Tags

Describes how to assign tags.

You can assign tags to objects individually, or to all the objects generated from 
a source file. You can also assign tags to objects in the Repository pane, by 
selecting the objects and choosing Assign/Remove Tags in the right-click 
menu. Select a project or folder to assign tags to every first-level object in the 
project or folder.

TASK

1. In the Object List pane, select the object(s) you want to assign a tag and 
choose Edit > Assign/Remove Tags. The Entity Tag Browser window 
opens.
5



MANAGING TAGS
REMOVING TAGS
2. In the Entity Tag Browser window, select the tag(s) you want to assign 
and click the Assign button.

3. If you are assigning a tag to a legacy source file, check Apply to 
Derived Objects to assign the selected tag(s) to all objects generated 
from the source file.

4. Click OK to assign the selected tags.

RESULT: The Object Tag column for the selected object(s) is updated to show the 
assigned tag(s) in the Objects List pane.

Removing Tags

Describes how to unassign tags.

Removing a tag simply “unassigns” the tag from the selected object. The tag is 
not deleted from the repository. You can also remove tags from objects in the 
Repository pane, by selecting the objects and choosing Assign/Remove Tags in 
the right-click menu. Select a project or folder to remove tags from every 
first-level object in the project or folder.

TASK

1. In the Object List pane, select the object(s) for which you want to 
remove tags and choose Edit > Assign/Remove Tags. The Entity Tag 
Browser window opens.
 6



MANAGING TAGS
CREATING RELATIONSHIPS BETWEEN TAGS
2. In the Entity Tag Browser window, select the tag(s) you want to remove 
and click the Remove button.

3. If you are removing a tag from a legacy source file, check Apply to 
Derived Objects to remove the selected tag(s) from all objects gener-
ated from the source file.

4. Click OK to remove the selected tags.

RESULT: The Object Tag column for the selected object(s) is updated in the 
Objects List pane.

Creating Relationships Between Tags

Describes how to create relationships between tags.

The relationships between tags define the tag hierarchy. Create relationships 
between tags as described below.

TASK

1. Choose Edit > Reference in the Tag Manager window. The References 
window opens. 

2. In the References window, click the  button on the toolbar. 

3. The Select dialog opens. Select the tags you want to create relation-
ships between and click OK. 

NOTE:  You can also draw relationships between tags by clicking the  
button on the toolbar. Select the first tag in the relationship and drag the 
mouse to the second tag in the relationship, then release the mouse button. 
See the Diagrammer help for instructions on how to use the other diagram-
ming functions in the References window.

RESULT: The tool draws a line between the referenced tags. To delete a relation-
ship line, select it and click the  button on the toolbar.
7



MANAGING TAGS
DELETING TAGS
Deleting Tags

Describes how to delete tags.

To delete tags from the repository, select them in the Tags pane and choose Edit 
> Delete Tags. You can also delete tags in the References window, by selecting 
them and clicking the  button on the toolbar.

Creating Tag Queries

Describes how to create tag queries.

Use tag queries to filter the objects in the Object List pane in more complex ways 
than the other panes allow. Create a tag query as described below.

TASK

1. Choose Query > New Query in the Tag Manager window. A dialog box 
prompts you to enter the name of the new query. Enter the name and 
click OK. The query is displayed in the Query pane.

2. Select the query in the Query pane and choose Query > Edit Query. 
The Query window opens.

3. Define the terms of the query. Click in the term field you want to define, 
then select the tag you want to add to the term definition and click 
 8



MANAGING TAGS
DELETING TAG QUERIES
Add. Tags added to the same term are ORed. Tags added to a different 
term are ANDed. Click Clear to clear the term definition.

4. When you are satisfied with the query definition, click OK.

Deleting Tag Queries

Describes how to delete tag queries.

To delete a tag query, select it and choose Delete in the right-click menu.

Refreshing the Tag Manager Window

Describes how to refresh the Tag Manager window.

To refresh the Tag Manager window with the latest information from the repos-
itory, including changes made by other users, click the  button next to the 

 button on the toolbar and choose Refresh in the drop-down menu. If 
objects have been deleted from the repository, they will remain visible in the 
Object List pane until you clean up the Tag Manager window. 

Cleaning Up the Tag Manager Window

Describes how to clean up the Tag manager window.

When objects are deleted from the repository, Tag Manager continues to 
display them in the Object List pane until you clean up the Tag Manager 
window. To clean up the window, click the  button next to the  button on 
the toolbar and choose Clean Up in the drop-down menu. 

NOTE:  This feature is only available to master users. Running a clean up may take 
several minutes, depending on the size of your repository.
9



MANAGING TAGS
GENERATING REPORTS
Generating Reports

Describes how to generate Tag Manager reports.

To generate an HTML report for all objects currently displayed in the Object 
List pane, choose File > Save Report.
 10



 

2
 Analyzing Relationship
Flows
Use the Diagrammer to view the relationships between objects in a scope, a data 
flow or call map, for example. These relationships describe the ways in which 
objects in the scope interact. In the data flow fragment below, for example, the 
GSS2 program reads the file GSS2.STATEMS. The file, in turn, is assigned to the 
CXXCP.OPK00.SNFILE data store. 

The Diagrammer’s high-level analysis of relationships lets you quickly trace the 
flow of information in an application. You can use it to view program to 
program calls; program, transaction, and screen flows; job, program, and data 
store flows; and much more. 
11



ANALYZING RELATIONSHIP FLOWS
UNDERSTANDING RELATIONSHIP FLOW DIAGRAMS
Understanding Relationship Flow Diagrams

Describes relationship flow diagrams. 

Relationship flow diagrams use boxes and lines to show the relationships 
between objects in a scope. Depending on the Diagrammer mode, you can 
display the relationships for: 

• All the objects in the selected project. 

• Only the objects you copy and paste onto the canvas. 

In each mode, all related workspace objects are included in the diagram. In 
copy-and-paste mode, you can add objects to an existing diagram and expand 
the diagram one level at a time. 

Objects are color-coded, based on a color scheme of your choosing. If you have 
assigned business names to objects, their business names appear in the diagram 
as well as their technical names. You can “black-box” items in higher-level 
groupings that make it easy to visualize their roles in your application, cluster 
highly related objects, filter drivers and utilities, and much more. 

Understanding Diagram Scopes

Explains diagram scopes.

The scope of a diagram determines the relationships it displays. To view a 
diagram of the relationships, select the scope in the Scope drop-down and 
choose Scope > View Scope. 

The Diagrammer provides default scopes that you can use for most analysis 
tasks, but you can create your own scopes if you like. You might want to exclude 
data stores from a data flow, or include source files in a call map. Use the Scope 
Editor to create your own scopes.
 12



ANALYZING RELATIONSHIP FLOWS
UNDERSTANDING DIAGRAM LAYOUTS
Understanding Diagram Layouts

Describes diagram layouts.

Diagrammer layout styles are designed to produce aesthetically pleasing, 
easy-to-understand diagrams for a wide variety of needs. To choose a layout 
style, click the  symbol on the button for the active layout style, then select the 
layout style in the drop-down menu. The following styles are available:

• The symmetric layout style (the default) organizes nodes based on symme-
tries detected in their relationships. Click the  button to choose the 
symmetric layout style.

NOTE:  The symmetric style typically offers the best performance for very 
large diagrams. 

• The hierarchical layout style organizes nodes in precedence relationships, 
with levels for parent and child object types. Click the  button to choose 
the hierarchical layout style.

• The orthogonal layout style organizes nodes in relationships drawn with 
horizontal and vertical lines only. Click the  button to choose the 
orthogonal layout style.

• The tree layout style organizes nodes in parent-child relationships, with 
child nodes arranged on levels farther from the root node than their 
parents. Click the  button to choose the tree layout style.

• The circular layout style organizes nodes in clusters of related objects. 
Click the  button to choose the circular layout style.

Click a layout style button in the drop-down to change the style after a diagram 
is drawn.

Generating a Diagram for the Selected Project

Describes how to generate a diagram for a project.

Follow the instructions below to generate a relationship flow diagram for the 
selected project. You can exclude related workspace objects that are not in the 
project, colorize project boundaries, and show incomplete relationship chains. 
You can use tags to “black-box” objects in the diagram.
13



ANALYZING RELATIONSHIP FLOWS
GENERATING A DIAGRAM FOR OBJECTS COPIED AND PASTED ONTO THE CANVAS
TASK

1. In the Scope drop-down, choose the scope of the diagram. 

2. On the Diagram pane tool bar, choose the layout style for the diagram.

3. in the Project drop-down or Browser pane, select the project. 

4. Click the  button on the Diagrammer tool bar

Generating a Diagram for Objects Copied and 
Pasted onto the Canvas

Describes how to generate a diagram for copied-and-pasted objects.

Follow the instructions below to generate a relationship flow diagram for 
objects copied and pasted onto the canvas. In this mode, you can expand the 
diagram one level at a time and add objects to an existing diagram. You can 
exclude related workspace objects that are not in the project, colorize project 
boundaries, and show incomplete relationship chains. You can use tags to 
“black-box” objects in the diagram.

TASK

1. In the Scope drop-down, choose the scope of the diagram. 

2. On the Diagram pane tool bar, choose the layout style for the diagram.

3. in the Browser pane, select the startup objects for the diagram, then 
press CTRL-C to copy them onto the clipboard. 

NOTE:  Make sure to select startup objects in the diagram’s intended scope. 
Most scopes include logical objects rather than source files.

4. To show the entire relationship flow for the selected objects, choose 
View > Auto Expand. Turn off Auto Expand if you want to expand the 
diagram one level at a time after it is drawn. Only immediate relation-
ships of the selected objects are drawn initially.

5. Click in the Diagram pane, then choose Diagram > Paste or press 
CTRL-V to paste the objects onto the Diagrammer canvas. 

6. Repeat the preceding step for each object whose relationships you 
want to add to the diagram. The diagram is automatically redrawn.
 14



ANALYZING RELATIONSHIP FLOWS
UNDERSTANDING THE DIAGRAMMER WINDOW
Understanding the Diagrammer Window

Describes the Diagrammer window.

Use the Diagrammer to view the relationships between application objects 
interactively. To open the Diagrammer, select a project in the Repository 
Browser and choose Analyze > Diagram. 

The figure below shows the Diagrammer window. By default, all Diagrammer 
panes are displayed. Select the appropriate choice in the View menu to hide a 
pane. Select the choice again to show the pane. 
15



ANALYZING RELATIONSHIP FLOWS
UNDERSTANDING THE DIAGRAMMER WINDOW
Diagram Pane

Describes the Diagram pane.

The Diagram pane displays the diagram for the selected scope. To save a 
diagram in one of the supported diagram formats, click the  on the Diagram 
pane tool bar. To save a diagram in one of the supported image formats, click 
the  on the Diagram pane tool bar. 

To print a diagram, click the  button on the Diagram pane tool bar. To 
preview the printed diagram, click the  button on the Diagram pane tool bar.

Selecting an Object or Relationship

Describes how to select objects or relationships.

To enable select mode, click the  button on the Diagram pane tool bar. 

• To select an object in a diagram, click it on the diagram canvas. Use 
Ctrl-click to select multiple objects, or click a blank area of the canvas, 
then drag the mouse over multiple objects to “lasso” the objects. Selected 
objects are displayed with handles that you can use to size the object.

• To select a relationship in a diagram, click it on the diagram canvas. The 
selected relationship is displayed in blue.

Searching for an Object

Describes how to search for an object.

To search for an object in a diagram, enter the text you want to match in the 
Search field on the Diagrammer tool bar and press Enter. You can use wildcard 
patterns allowed in LIKE statements by Visual Basic for Applications (VBA).

Navigating to an Object from a Relationship

Describes how to navigate to an object from a relationship.

To navigate to the diagram object on the left side of a relationship, select the 
relationship and choose Locate Left in the right-click menu. To navigate to the 
diagram object on the right side of a relationship, select the relationship and 
choose Locate Right in the right-click menu. 

NOTE:  Use the Overview pane to navigate to general locations in a diagram.
 16
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UNDERSTANDING THE DIAGRAMMER WINDOW
Expanding and Collapsing Relationships

Describes how to expand and collapse relationships.

To expand the incoming relationships for an object in a diagram generated in 
copy-and-paste mode, select the object on the diagram canvas and choose 
Expand > Expand Incoming in the right-click menu. To expand the outgoing 
relationships, select the object on the diagram canvas and choose Expand > 
Expand Outgoing in the right-click menu.

To collapse the incoming relationships for an object, select the object on the 
diagram canvas and choose Collapse > Collapse Incoming in the right-click 
menu. To expand the outgoing relationships, select the object on the diagram 
canvas and choose Collapse > Collapse Outgoing in the right-click menu.

Moving an Object or Relationship

Describes how to move an object or relationship.

To move an object or relationship in a diagram, select it and drag it to the 
desired location on the diagram canvas.

Resizing an Object

Describes how to resize an object.

To resize an object in a diagram, select it on the diagram canvas and drag one of 
its handles to the desired location.

Hiding an Object

Describes how to hide objects on the canvas.

To hide objects on the canvas, select an object and choose:

• Hide > Selected in the right-click menu to hide the selected object. 

• Hide > Incoming in the right-click menu to hide incoming nodes of the 
selected object. 

• Hide > Outgoing in the right-click menu to hide outgoing nodes of the 
selected object.

 To display the object again, double-click the  button for a related object. 
17
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UNDERSTANDING THE DIAGRAMMER WINDOW
Deleting an Object or Relationship

Describes how to delete an object or relationship from a diagram.

To delete an object in a diagram, select the object on the diagram canvas and 
choose Delete Node in the right-click menu. To delete a relationship in a 
diagram, select the relationship on the diagram canvas and choose Delete Edge 
in the right-click menu. 

Assigning Tags

Describes how to assign tags in the Diagrammer. 

You can assign tags manually in Diagrammer or automatically, to all the objects 
in a cluster. Follow the instructions below to assign tags manually. 

TASK

1. Select the objects you want to assign tags on the diagram canvas and 
choose Assign Tags in the right-click menu. The Entity Tag Browser 
window opens. 

2. In the Entity Tag Browser window, select the tag(s) you want to assign 
and click the Assign button.

3. If you are assigning a tag to a legacy source file, check Apply to 
Derived Objects to assign the selected tag(s) to all objects generated 
from the source file.

4. Click OK to assign the selected tags.

Assigning Business Names

Describes how to assign and unassign a business name and business description.

To assign a business name and business description to an object, select the 
object and choose Set Business Attributes in the right-click menu. A dialog box 
opens, where you can enter the business name and business description. To 
unassign a business name or business description, simply delete the value in the 
dialog box.

NOTE:  If multiple objects are selected, Diagrammer displays the dialog box as 
many times as there are objects.
 18
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UNDERSTANDING THE DIAGRAMMER WINDOW
Displaying Labels for Multiple Relationships

Describes how to display the labels for multiple relationships.

The Diagrammer denotes that an object has multiple relationships with another 
object by displaying a number in parentheses (n) along the relationship line, 
where n represents the number of relationships. Double-click the parenthesis to 
display the relationship labels. Double-click the relationship labels to hide them 
again.

Hiding Relationship Labels

Describes how to hide relationship labels on the canvas.

To hide relationship labels on the canvas, click the  button on the tool bar 
and choose Hide Relationship Labels in the drop-down menu. To show the 
relationship labels again, click the  button on the tool bar and choose Show 
Relationship Labels in the drop-down menu. To show hidden nodes as well as 
hidden relationship labels, click the  button on the tool bar and choose 
Unhide All in the drop-down menu. 

Displaying the Legend for a Diagram

Describes how to display the legend for a diagram.

To display the legend for a diagram, click the  button on the tool bar and 
choose Show Legend in the drop-down menu. 

Zooming

Describes how to zoom in a diagram.

To zoom in interactive mode, click  button on the Diagram pane tool bar, 
then drag the mouse over the diagram to zoom on it.

To zoom in marquee mode, click  button on the Diagram pane tool bar, then 
drag the mouse over the diagram to draw a marquee. The Diagrammer displays 
the portion of the diagram inside the marquee.

To fit the diagram in the Diagram pane, click the  button on the Diagram 
pane tool bar.
19
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UNDERSTANDING THE DIAGRAMMER WINDOW
Moving a Diagram

Describes how to move a diagram.

To move a diagram in the Diagram pane, click the  button on the Diagram 
pane tool bar to choose panning mode, then hold down the left mouse button 
and drag the mouse to move the diagram.

Clearing a Diagram

Describes how to clear a diagram.

To clear the Diagram pane, choose Diagram > Clear.

Browser Pane

Describes the Browser pane.

The Browser pane displays the workspace repository in tree form. The current 
project is expanded one level when you first open the Diagrammer. 

NOTE:  To improve Diagrammer startup performance in your next session, hide 
the Browser pane before you end your current session. Click the close box in the 
upper righthand corner to hide the pane. To show the pane again, choose View > 
Browser.

Relationships Pane

Describes the Relationships pane.

The Relationships pane displays the relationships in the selected scope, as they 
appear from left to right in the diagram. Select the relationship for an object in 
the Relationships pane to navigate to the object in the Diagram pane.

The list includes relationship chains, or composite relationships, such as 
Program[IsDefinedInCobol]Cobol[Includes]Copybook[GeneratesTar-
getXml]TargetXML. If you chose View > Potential Incomplete Composite 
Relationships when you drew the diagram, the list shows incomplete relation-
ship chains, in which the final object in the chain is unresolved or otherwise 
unavailable. 
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Quick View Pane

Describes the Quick View pane.

The Quick View pane lets you browse HyperView information for the object 
selected in the Diagram pane. The information available depends on the type of 
object selected. You see only source code for a copybook, for example, but full 
HyperView information for a program. Choose the information you want to 
view for the object from the drop-down in the upper lefthand corner of the 
pane.

Overview Pane

Describes the Overview pane.

The Overview pane lets you navigate to a general location in a diagram. It 
displays the entire diagram, with a frame surrounding the portion of the 
diagram visible in the Diagram pane. Drag the frame to the area of the diagram 
you want to view in the Diagram pane. Diagrammer displays the selected area 
in the Diagram pane.

Excluding Objects Outside the Project

Describes how to exclude objects outside the project from a diagram.

To restrict the diagram to related objects in the current project, choose View > 
Exclude Objects Outside Project. Otherwise, all related workspace objects are 
included in the diagram.

Showing Incomplete Composite Relationships

Describes how to show incomplete composite relationships in the Diagrammer.

A composite relationship defines the indirect interaction of two objects. If a job 
runs a program entry point that belongs to a program, for example, the relation-
ship between the job and program is said to be composite: defined by the chain 
of relationships between the job and program. 
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To show incomplete relationship chains in the diagram and list of relationships, 
choose View > Potential Incomplete Composite Relationships. Intermediate 
objects in the chain are displayed even if the final object in the chain is unre-
solved or otherwise unavailable. Relationships are displayed in red in the 
diagram. 

Colorizing Project Boundaries

Describes how to colorize project boundaries in a diagram.

Boundary objects are objects with relationships to objects outside the project. To 
colorize boundary objects in the diagram, choose View > Project Boundary 
Entities. Boundary objects are displayed in the diagram with a red border. 
Related external objects are displayed in the diagram with a blue border. 

Showing and Hiding Object Labels

Describes how to show and hide object labels.

The View > Show in Label menu choice controls the labels displayed for objects 
in a diagram. Choose:

• View > Show in Label > Show Type to display the type of an object in its 
label. 

• View > Show in Label > Show Name to display the name of an object in 
its label. 

• View > Show in Label > Show Business Name to display the business 
name of an object in its label. 

• View > Show in Label > Show Business Description to display the busi-
ness description of an object in its label. 

 A check mark next to a choice means that the label will be displayed. The 
choices are toggles. Click the choice again to hide the information in the label. 
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Working with Groups

Introduces the Diagrammer grouping feature. 

Grouping objects reduces diagram clutter and makes it easy to visualize the 
roles of the grouped objects in your application. Groups are automatically 
created when you black-box tagged objects and when you filter or cluster 
objects. 

Grouping and Ungrouping Objects

Describes how to group and ungroup objects. 

To group objects manually, select the objects on the diagram canvas, then click 
the  button on the tool bar and choose Group Selected in the drop-down 
menu. Inclusive groups are allowed. 

To ungroup objects, select the group on the diagram canvas, then click the  
button on the tool bar and choose Ungroup Selected in the drop-down menu. 

Expanding and Collapsing Groups

Describes how to expand and collapse groups. 

Expand a group to view its contents. Collapse a group to hide its contents. 

• If a group is collapsed (including a group in a more inclusive group), 
double-click it to expand its contents. To expand all the groups in an 
inclusive group, select the group on the diagram canvas, then click the  
button on the tool bar and choose Expand Groups in the drop-down 
menu. 

• If a group is expanded (including a group in a more inclusive group), 
double-click it to collapse it. To collapse all the groups in an inclusive 
group, select the group on the diagram canvas, then click the  button 
on the tool bar and choose Collapse Groups in the drop-down menu. 

To view a diagram consisting only of objects in a group, select the group and 
choose Navigate to Child Diagram in the right-click menu. To restore the full 
diagram, click the  button on the tool bar and choose Return to Parent in 
the drop-down menu. 
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Moving Objects Between Groups

Describes how to move objects between groups. 

To move objects between groups, expand the groups, then click the  button 
on the toolbar. Select the object you want to move and drag it to the new group. 

Naming Groups

Describes how to name a group. 

To rename a group, select it and choose Rename Group in the right-click menu. 

NOTE:  The name does not persist after ungrouping. You cannot rename a black 
box. 

Deleting Groups

Describes how to delete a group. 

To delete a group, select it and choose Delete Group in the right-click menu. 
You are prompted to confirm the deletion. Click Yes. 

Black-Boxing Tagged Objects

Describes how to black-box tagged objects in a diagram. 

The deeper your understanding of your application, the more confidently you 
can abstract from its lower-level details to a “bigger picture” view, one that orga-
nizes related programs in functional, structural, or other types of groupings: a 
Customer Maintenance subsystem, for example, in an Order Acceptance appli-
cation. This is the kind of view a subject matter expert uses to evaluate whether 
an application does everything it is supposed to do, in the appropriate order. 

The Diagrammer black-box feature lets you assign lower-level objects to 
higher-level groupings that make it easy to visualize their roles in your applica-
tion. Your diagram might have one black box for the Customer Maintenance 
subsystem, another for the Order Entry subsystem, and so forth. Because the 
details of these relationships are hidden in the black box until you need to view 
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them, the subject matter expert can home in quickly on the higher-order func-
tions you have abstracted from them. 

You use the Tag Manager to identify the items in each higher-level grouping. 
Each grouping can, in turn, reference a more inclusive grouping. If you assign 
the Customer Maintenance tag to one set of programs, for example, and the 
Order Entry tag to another, and both tags reference the Application Functions 
tag, then when you choose Application Functions in the Diagrammer Group By 
drop-down, the Diagrammer puts the programs in black boxes named Applica-
tion Functions Customer Maintenance and Application Functions Order Entry. 

TASK

1. To black-box objects in a diagram, choose the tag for the objects in the 
Group By drop-down. 

NOTE:  To show only top-level tags in the drop-down, choose View > Root 
Tags Only. 

2. Generate the diagram in project or copy-and-paste mode. The figure 
below shows expected results. 
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Filtering Objects

Describes how to filter objects from a diagram. 

A driver is an object with many outputs, a startup program, for example. A 
utility is an object with many inputs, DATEFMT, for example. Filtering drivers 
and utilities from large diagrams reduces diagram clutter and typically provides 
a better picture of what your application does. 

You set thresholds for filtering in the Diagrams User Preferences. If you set the 
driver threshold for outgoing relationships to 40, for example, then any object 
with 40 or more outgoing relationship will be considered a driver and displayed 
outside the main relationship flow. The driver and its related nodes in the rela-
tionship flow appear with a  symbol in the diagram. Click the  symbol to 
display the relationships for the driver and its related nodes again. 

You generate a filtered diagram the same way you generate any diagram. The 
only difference is that when the filtering thresholds are met, Diagrammer 
displays the Large Dataset Returned dialog. Choose Enable Node Filtering in 
the dialog to draw the diagram with the filter applied. Choose Disable Node 
Filtering and Clustering in the dialog to draw the diagram without the filter 
applied. A  symbol on the tool bar indicates that a diagram is filtered. 

TIP:  Use the Filter Override options on the  drop-down menu to override the 
thresholds in the Diagrams User Preferences. If the diagram has already been 
generated, choosing an override option redraws the diagram with the new filter 
applied. 

Setting Filter Overrides

Describes how to set filtering overrides. 

Use the Filter Override Options window to override the filtering thresholds in 
the Diagrams User Preferences. If the diagram has already been generated, 
choosing an override option redraws the diagram with the new filter applied. 

NOTE:  These settings do not persist between Diagrammer sessions. 

TASK

1. Click the  button on the tool bar and choose Filter Override in the 
drop-down. The Filter Override Options window opens. 

2. Select Filters Enabled to enable filtering. 
 26



ANALYZING RELATIONSHIP FLOWS
CLUSTERING OBJECTS
3. Select Hide Utilities to hide objects with many inputs, DATEFMT, for 
example. Specify the filtering thresholds for inputs and outputs: 
• In the Incoming Relationships field, enter the filtering threshold for 

incoming relationships. 

• In the Outgoing Relationships field, enter the filtering threshold for 
outgoing relationships. 

4. Select Hide Drivers to hide objects with many outputs, a startup 
program, for example. Specify the filtering thresholds for inputs and 
outputs: 
• In the Incoming Relationships field, enter the filtering threshold for 

incoming relationships. 

• In the Outgoing Relationships field, enter the filtering threshold for 
outgoing relationships. 

5. Select Hide High Input Nodes to hide objects with many inputs that 
do not meet the incoming relationship threshold for utilities. Specify 
the thresholds for inputs in the With Incoming Relationships field. 

6. Select Hide High Output Nodes to hide objects with many outputs 
that do not meet the outgoing relationships threshold for drivers. 
Specify the thresholds for outputs in the With Outgoing Relation-
ships field. 

TIP:  Select Reset Values to restore the filtering thresholds to their settings in the 
Diagrams User Preferences. 

Clustering Objects

Describes how to cluster objects on a diagram. 

Clustering objects on a diagram groups them by their degree of relatedness. 
Once clusters are generated, you can move objects in and out of the groups, 
name the groups, and create new clusters as needed. When you are satisfied that 
a cluster meets your needs, you can assign an existing tag to its members or 
generate a tag from the cluster itself, each member of which receives the tag. 

You enable clustering in the Diagrams User Preferences. Use the Clustering 
options on the  drop-down menu to specify clustering factors. Assuming the 
appropriate filtering thresholds are me, drivers and utilities are grouped in 
special clusters named "Drivers" and "Utilities." A third special cluster, "Miscel-
laneous Components," contains relationship flows with too few objects to 
cluster. 
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You generate a clustered diagram the same way you generate any diagram. The 
only difference is that Diagrammer displays the Large Dataset Returned dialog. 
Choose Enable Node Clustering in the dialog to draw the diagram with clus-
tering applied. Choose Disable Node Filtering and Clustering in the dialog to 
draw the diagram without clustering applied. 

Creating Clusters Manually

Describes how to create clusters manually. 

To create a cluster manually, right-click on white space on the Diagrammer 
canvas. The Clustering dialog opens. Select Create New Cluster, then enter the 
cluster name in the Cluster Name field. Click OK. 

Generating Tags from Clusters

Describes how to generate tags based on cluster names. 

To generate tags based on cluster names, right-click on white space on the 
Diagrammer canvas. The Clustering dialog opens. Select Create Tags from 
Clusters, then enter the name of the parent tag in the Top Level tag field. 

NOTE:  The parent tag is required. 

Click OK. Each member of a cluster is assigned a tag based on the cluster name. 

Setting Clustering Factors

Describes how to set clustering factors. 

Use the Clustering Options window to specify values by which the degree of 
relatedness between clustered objects is factored. 

NOTE:  These settings do not persist between Diagrammer sessions. 

TASK

1. Click the  button on the tool bar and choose Clustering in the 
drop-down. The Clustering Options window opens. 
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2. In the Quality drop-down, select: 
• Draft for the lowest clustering quality and best performance. 

• Proof for the highest clustering quality and worst performance. 

• Medium for the best balance of clustering quality and performance. 

3. In the Balance combo box, specify the clustering balance factor. The 
higher the balance factor, the lower the number of relationships 
between objects in different clusters. 

4. In the Cluster Size Factor combo box, specify the clustering size factor. 
The higher the clustering size factor, the larger and fewer the clusters. 

5. In the Max Number of Clusters combo box, specify the maximum 
number of clusters. A value of 0 means any number of clusters. 

6. In the Min Number of Clusters combo box, specify the minimum 
number of clusters. A value of 0 means any number of clusters. 

Setting Diagrams User Preferences

Describes how to set Diagrams User Preferences. 

Use the Diagrams tab of the User Preferences window to specify the 
color-coding used in relationship flow diagrams, the thresholds for clustering 
and filtering, and performance limits for large diagrams. 

TASK

1. Choose Tools > User Preferences. The User Preferences window 
opens. Click the Diagrams tab. 

2. Select Prompt When Diagram Mode Changes to be prompted when 
you switch between a diagram generated for a project and a diagram 
generated for copied-and-pasted objects. 

3. In the Color Scheme pane, click the object type whose color you want 
to edit. The current background color of the type (if any) is displayed in 
the Color drop-down. 

4. Click the adjacent  button and choose ForeColor from the pop-up 
menu if you want to specify the color of the caption for the object type, 
or BackColor if you want to specify the color of the background for the 
object type. 
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5. In the Shape drop-down, select the shape of the object type in the 
diagram. Select Lock Shape Aspect to specify that the shape not be 
adjusted to fit the caption. 

6. Click the Performance button. The Performance Option Limits dialog 
opens. 

7. Deselect Relayout Subgraphs if you do not want child groups to be 
redrawn when you choose a new layout style. 

NOTE:  Selecting this option may result in poor performance for very large 
diagrams. 

8. In the Maximum relationships to return from repository field, enter 
the maximum number of relationships to display in the diagram. Rela-
tionships are truncated when the maximum is exceeded. 

NOTE:  Setting this option too high may result in poor performance for very 
large diagrams. 

9. In the Force Symmetric Layout (all relationships) field, enter the 
maximum number of relationships to display in the diagram before 
forcing symmetric layout style. 

NOTE:  Symmetric layout style typically offers the best performance for very 
large diagrams. Setting this option too high may result in poor performance 
for very large diagrams. 

10. In the Offer Auto Clustering Layout (all relationships) field, enter the 
maximum number of relationships to display in the diagram before 
offering to perform clustering. 

11. Select Filter Options Enabled to enable filtering. 

12. In the Hide Drivers (all relationships) field, enter the maximum 
number of relationships to display in the diagram before filtering 
drivers. (A driver is an object with many outputs, a startup program, for 
example.) Specify the filtering thresholds for inputs and outputs: 
• In the Incoming Relationships field, enter the filtering threshold for 

incoming relationships. 

• In the Outgoing Relationships field, enter the filtering threshold for 
outgoing relationships. 

13. In the Hide Utilities (all relationships) field, enter the maximum 
number of relationships to display in the diagram before filtering utili-
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ties. (A utility is an object with many inputs, DATEFMT, for example.) 
Specify the filtering thresholds for inputs and outputs: 
• In the Incoming Relationships field, enter the filtering threshold for 

incoming relationships. 

• In the Outgoing Relationships field, enter the filtering threshold for 
outgoing relationships. 

14. In the Hide High Output Nodes (all relationships) field, enter the 
maximum number of relationships to display in the diagram before 
filtering objects with many outputs that do not meet the outgoing rela-
tionships threshold for drivers. Specify the filtering thresholds for 
outputs in the Outgoing Relationships field. 

15. In the Hide High Input Nodes (all relationships) field, enter the 
maximum number of relationships to display in the diagram before 
filtering objects that do not meet the incoming relationship threshold 
for utilities. Specify the filtering threshold for inputs in the Incoming 
Relationships field. 

Using the Scope Editor

Describes the Scope Editor.

Use the Scope Editor to manage the scopes in your repository, create custom 
composite relationships, and define relationship filters. To open the Scope 
Editor, choose Scope > Scope Editor. The Scope Editor opens, with the work-
space scopes listed in the lefthand pane and their relationships in the righthand 
pane. The figure below shows the Scope Editor.
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Understanding the Lefthand Pane of the Scope Editor

Describes the lefthand pane of the Scope Editor.

The lefthand pane of the Scope Editor window lists every scope in the reposi-
tory. The table below describes the columns in the lefthand pane.

Column Description

Scope The name of the scope. Scopes are color-coded as 
follows:
• Blue means that the scope is available in the 

Diagrammer Scope drop-down.
• Gray means that the scope is not available in the 

Scope drop-down, because it is hidden or because 
it is a private scope owned by another user. You can 
copy a private scope, then edit it as you would your 
own scope

• Red means that the scope has no relationships 
associated with it. 
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Understanding the Righthand Pane of the Scope Editor

Describes the righthand pane of the Scope Editor.

The righthand pane of the Scope Editor window lists every relationship in the 
repository. The table below describes the columns in the righthand pane.

Type The type of the scope, public or private. The type 
determines availability of the scope in the 
Diagrammer Scope drop-down:
• A public scope is available to every user of the 

workspace.
• A private scope is available only to its owner. You 

can copy a private scope, then edit it as you would 
your own scope.

Owner The owner of the scope. SYSTEM denotes a default 
scope.

Hide Whether the scope is hidden in the Diagrammer 
Scope drop-down. A check mark means that the 
scope is hidden.

Column Description

Column Description

Use Whether the relationship is used in the selected scope. 
A check mark means that the relationship is used.

Relationship Name The name of the relationship. Relationships for which 
a filter has been defined are color-coded magenta.

Left Entity The entity on the left end of the relationship. Entities 
for which a relationship filter has been defined are 
color-coded magenta. A tool tip displays the text of 
the condition.

Caption The caption of the relationship.

Right Entity The entity on the right end of the relationship. Entities 
for which a relationship filter has been defined are 
color-coded magenta. A tool tip displays the text of 
the condition.
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Managing Scopes

Introduces scope management.

Use the Scope Editor to edit the Diagrammer Scope drop-down, view scope 
diagrams, create, edit, copy, and delete scopes, import and export scopes, and 
more.

Hiding a Scope in the Scope Dropdown

Describes how to hide a scope.

To hide a scope in the Diagrammer Scope drop-down (but not remove it from 
the repository), select the scope in the Scope Editor and put a check mark next 
to it in the Hide column.

Displaying Only the Relationships Used in a Scope

Describes how to hide unused relationships.

To display only the relationships used in a scope, select the scope in the Scope 
Editor and click the Hide Unused button in the righthand pane.

Hiding Empty Relationships

Describes how to hide empty relationships.

Class The class of the relationship, basic or composite:
• A basic relationship defines the direct interaction 

of two objects: a program and a program entry 
point, for example.

• A composite relationship defines the indirect inter-
action of two objects. If a job runs a program entry 
point that belongs to a program, for example, the 
relationship between the job and program is said to 
be composite: defined by the chain of relationships 
between the job and program.

Occurs The number of times a basic relationship occurs in the 
repository. For composite relationships, N/A, 
indicated with an asterisk (*).

Column Description
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To hide relationships that have no instances in the repository, click the Hide 
Empty button in the righthand pane. 

Viewing a Diagram of a Scope

Describes how to view a scope diagram.

To view the diagram of a scope, select the scope in the Scope Editor and choose 
File > Diagram. You can also view a scope diagram by selecting the scope in the 
Diagrammer Scope drop-down and choosing Scope > View Scope. 

Viewing a Diagram of a Composite Relationship

Describes how to view a diagram of a composite relationship.

To view the diagram of a composite relationship, select the relationship in the 
Scope Editor and choose Diagram in the right-click menu.

Creating a Scope

Describes how to create a scope.

To create a scope, choose File > New Scope. A dialog box prompts you to enter 
the name, optional caption, class, and owner of the scope. Enter the requested 
information and click Save. 

Specifying the Relationships in a Scope

Describes how to specify the relationships in a scope.

To specify the relationships in a scope, select the scope in the Scope Editor and 
put a check mark in the Use column next to each relationship you want to 
include in the scope. To save the scope, choose File > Save. 

NOTE:  You can specify relationships only for a scope you own. 

Editing Scope Details

Describes how to edit scope details.

To edit the name, caption, class, and owner of a scope, select the scope in the 
Scope Editor and choose File > Edit. A dialog box displays the current details 
for the scope. Enter the new information and click Save. 

NOTE:  You can edit details only for a scope you own.
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Copying a Scope

Describes how to copy a scope.

To copy a scope, select the scope in the Scope Editor and choose File > Copy. A 
dialog box prompts you to enter the name, optional caption, class, and owner of 
the new scope. Enter the requested information and click Save. You can copy 
default scopes and public or private scopes owned by another user, then edit 
them as you would your own scope. 

Deleting a Scope

Describes how to delete a scope.

To delete a scope, select the scope in the Scope Editor and choose File > Delete. 

NOTE:  You can delete only a scope you own. 

Deleting a Composite Relationship

Describes how to delete a composite relationship.

To delete a composite relationship, select the relationship in the Scope Editor 
and choose Delete in the right-click menu. 

NOTE:  You can delete only a composite relationship you own.

Importing and Exporting Scopes

Describes how to import and export scopes.

To import a scope from an XML file, choose File > Import. A dialog opens, 
where you can specify the scope you want to import. The type of an imported 
scope defaults to public. The owner defaults to the current user. 

NOTE:  If a scope or relationship being imported conflicts with an existing scope or 
relationship, you are notified and the conflicting item is ignored. 

To export a scope to an XML file, select the scope in the Scope Editor and choose 
File > Export Selected. A Save dialog opens, where you can specify the name 
and location of the scope. To export all the scopes in the repository to an XML 
file, choose File > Export All. 
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Hiding Columns in the Scope Editor

Describes how to hide columns in the Scope Editor.

To hide a column in the Scope Editor, deselect the column name in the View 
menu. 

Creating Custom Composite Relationships

Describes how to create custom composite relationships.

A composite relationship defines the indirect interaction of two objects. If a job 
runs a program entry point that belongs to a program, for example, the relation-
ship between the job and program is said to be composite: defined by the chain 
of relationships between the job and program. 

You can use the default composite relationships provided with the system, or 
use the Scope Editor to create custom composite relationships. Custom 
composite relationships are available to all users of the workspace. 

NOTE:  Custom composite relationships are not copied or exported when a scope 
is copied or exported.

TASK

1. In the Scope Editor, choose File > New Relationship. 

2. The New Relationship Wizard opens. In the Enter Relationship Name 
field, enter the name of the composite relationship, then select the 
object you want to appear on the left side of the relationship chain in 
the Select First Entity pane. Click Next. 

3. In the Select relationship pane, select the relationship you want to 
appear next in the relationship chain. Click Next. 

4. Repeat the preceding step for each relationship you want to include in 
the chain. When you are satisfied with your choices, click Finish. 
STEP RESULT: The New Relationship Wizard closes and the new composite rela-
tionship is added to the Scope Editor window.

Defining a Relationship Filter

Describes how to define a relationship filter.

You can define a relationship filter by setting conditions for either side of the 
relationships defined in a scope you own. You might want a scope to be 
restricted to programs that have a cyclomatic complexity greater than 300 and 
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that are defined in COBOL source files, for example. The example below shows 
you how to do that step by step.

Condition definitions are based on the Repository Exchange Protocol (RXP), an 
XML-based API that you can use to interact with application-level information 
in the workspace repository. 

In the Scope Editor, relationships and entities for which a filter has been defined 
are color-coded magenta. A tool tip over the filtered entity displays the text of 
the condition.

TASK

1. In the Scope Editor, select the relationship you want to set conditions 
for and choose:
• Left Cond in the right-click menu to qualify the entity on the left side of 

the relationship.

• Right Cond in the right-click menu to qualify the entity on the right side 
of the relationship.

2. The Condition window opens. In the Condition window, click:
• attribute to qualify the entity according to the value of a given attri-

bute. Programs that have a cyclomatic complexity greater than 300, for 
example.

• has (not) related object to qualify the entity according to a given rela-
tionship type. Programs defined in COBOL source files, for example.

• add AND condition to qualify the entity according to inclusive criteria 
using an AND operator. Programs that have a cyclomatic complexity 
greater than 300 and that are defined in COBOL source files, for 
example.

• add OR condition to qualify the entity according to exclusive criteria 
using an OR operator. Programs that have a cyclomatic complexity 
greater than 300 or that are defined in COBOL source files, for example.

3. The Condition window displays the shell definition for the selected 
condition. The following steps describe how to qualify the program 
entity using an AND operator. The procedure for other entities and 
conditions is similar.

4. In the definition for the AND condition, click attribute. The definition 
for the attribute condition is displayed:

     <attr name="..." op="..." arg="..." negate="..."/>

NOTE:  Click the X in a definition to delete the condition.

5. Click the ellipsis (…) in name="…". The User Input dialog opens. In the 
User Input dialog, select the Program entity in the Choose entity 
drop-down and the Cyclomatic Complexity attribute in the Attributes 
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for Program drop-down, then click OK. The attribute is added to the 
condition definition.

NOTE:  Click Delete in the User Input dialog to delete the criterion defined 
in the dialog.

6. Click the ellipsis (…) in op="…". The User Input dialog opens. In the 
Choose new value drop-down, choose the greater than (>) symbol, 
then click OK. The greater than symbol is added to the condition defi-
nition.

7. Click the ellipsis (…) in arg="…". The User Input dialog opens. In the 
Enter new value drop-down, enter 300, then click OK. The new value is 
added to the condition definition:

     <attr name="Cyclomatic Complexity" op=">" arg="300"
     negate="..."/>

NOTE:  In a condition definition, negate means “not the specified crite-
rion.” Programs that do not have a cyclomatic complexity greater than 300, 
for example. Click the ellipsis (…) in negate="…" to set its value to true. 
Ignore the field otherwise.

8. In the definition for the AND condition, click has (not) related object. 
The definition for the relationship type condition is displayed:

     <hasrelated negate="...">

9. In the choices for the relationship type condition, click define relation-
ship type. 

10. The choices for the relationship type are displayed. Click define rela-
tionship. The definition for the relationship type is displayed:

     <rel name="..." negate="..."/>

11. Click the ellipsis (…) in name="…". The User Input dialog opens. In the 
Choose entity drop-down, select the Program entity. In the Relations 
for Program drop-down, select the IsDefinedInCobol relationship, 
then click OK. The relationship is added to the condition definition:

     - <hasrelated negate="...">
     - <reltype>
     <rel name="IsDefinedInCobol" negate="..."/>
     </reltype>
     </hasrelated>

12. The AND condition is now complete. The diagram scope will be 
restricted to programs that have a cyclomatic complexity greater than 
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300 and that are defined in COBOL source files. The full condition looks 
like this:

     - <cond>
     <and negate="...">
     <attr name="Cyclomatic Complexity" op=">"
     arg="300" negate="..."/>
     - <hasrelated negate="...">
     - <reltype>
     <rel name="IsDefinedInCobol"
     negate="..."/>
     </reltype>
     </hasrelated>
     </and>
     </cond>

Pruning a Scope

Describes how to prune relationships from a scope.

You can prune relationships from a scope you own directly in the Diagrammer 
window. When you prune a scope, keep in mind that:

• You are deleting relationships from the current scope exactly as if you 
were deleting them in the Scope Editor window. For that reason, you 
might want to save the original scope with a different name and use the 
renamed scope as the basis for the pruned diagram.

• All the relationships of the selected type are deleted for the selected object, 
not just the single relationship you selected in the diagram.

TASK

1. To prune a scope, select the relationship you want to prune in the 
diagram and choose:
• Prune type for right object in the right-click menu to delete from the 

current scope all relationships of the selected type for the right object in 
the relationship.

• Prune type for left object in the right-click menu to delete from the 
current scope all relationships of the selected type for the left object in 
the relationship.

2. Generate the diagram in project or copy-and-paste mode. The 
Diagrammer deletes the relationships from the redrawn diagram.
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Mirroring a Scope

Describes how to mirror a scope.

By default, Diagrammer shows the flow of relationships from a diagrammed 
object rather than to a diagrammed object. Choose Scope > Mirror Scope to 
show the flow of relationships to the object. Choose Scope > Mirror Scope 
again to return to the original view.
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3
 Analyzing Global Data
Flows
The Global Data Flow tool traces incoming and outgoing data flows for a 
program variable up to a dataport, an I/O statement or call to or from another 
program. You can view the memory allocation and offset for the variable to 
determine how changes to the variable may affect other variables, and trace 
assignments to and from the variable across programs. 

NOTE:  Projects must have been verified with the Enable Data Element Flow 
option set in the Project Verification options.

The Global Data Flow tool is implemented as both a standalone and Hyper-
View-based tool. This section describes the standalone version. Usage is iden-
tical for the HyperView tool. 

Understanding the Global Data Flow Window

Describes the Global Data Flow window.

Use the Global Data Flow tool to trace incoming and outgoing data flows for a 
program variable up to a dataport, an I/O statement or call to or from another 
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program. To open the Global Data Flow tool, select a program in the Repository 
Browser and choose Analyze > Data Flow. 

The figure below shows the Global Data Flow window. By default, all Global 
Data Flow panes are displayed. Select the appropriate choice in the View menu 
to hide a pane. Select the choice again to show the pane. 

Data View Pane

Describes the Data View pane.

For the selected program, the Data View pane shows variable structures, 
substructures, and fields in hierarchical order from left to right. Double-click a 
variable name to generate a data flow diagram for the variable in the Data Flow 
pane, and a list of offsets and memory allocations for the variable and any 
related variables in the Origin pane.
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Data Flow Pane

Describes the Data Flow pane.

For the variable selected in the Data View pane, the Data Flow pane displays a 
diagram that traces its incoming and outgoing data flows up to a dataport, an 
I/O statement or call to or from another program. The selected variable is 
displayed in red, constants in gray, and dataports in blue. 

NOTE:  Make sure you have enabled incoming and/or outgoing data flows appro-
priately in the Global Data Flow project options.

Two diagram views are available:

• The Expanded View displays as many nodes for the selected variable as it 
has assignments. 

• The Compact View displays a single node, regardless of the number of 
assignments. 

Click the tab for the view you want to display. 

Select a dataport and choose Data Flow > Reconstruct to display the data flow 
diagram for the variable identified at the dataport. Select a relationship line to 
display all the statements that determine the data flow between variables in the 
Origin pane. 

Place your cursor over a variable for a moment to display a tool tip that identi-
fies the memory offset and allocation for the variable. The diagram uses 
Modernization Workbench common diagramming features.

Origin Pane

Describes the Origin pane.

For the variable selected in the Data View or Data Flow panes, the Origin pane 
displays a list of offsets and memory allocations for the variable and any related 
variables. For the dataport selected in the Data Flow pane, it displays related 
variables. For the relationship selected in the Data Flow pane, it displays the 
intraprogram or interprogram relationship detected by data flow analysis.
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Data Flow Relationships

Describes the intraprogram and interprogram relationships detected by the 
data flow analysis tools.

The table below describes the intraprogram and interprogram relationships 
detected by the data flow analysis tools.

Relationship Definition Type Icon Description

calls N/A interprogram N/A A parameter passed in a 
call to another program.

cast MOVE A TO 
B with data 
conversion

intraprogram A data item moved to a 
data item of a different 
type.

common area 
transitions

N/A interprogram N/A For Unisys 2200 Cobol, a 
common-storage data 
area item passed in a call 
to another program. 
Perform Unisys 
Common-Storage Area 
Analysis must be set in 
the project verification 
options.

comp STRING A ... 
INTO B 

intraprogram An arbitrary computation. 
The result is produced by 
applying complex rules to 
the argument, such as 
STRING.

comp+ ADD A TO B intraprogram An addition-like 
operation: ADD, 
SUBTRACT, or 
corresponding parts of 
COMPUTE.

comp* MULTIPLY 
A BY B

intraprogram A multiplication-like 
operation: MULTIPLY, 
DIVIDE, or 
corresponding parts of 
COMPUTE.

comp@ MOVE 
ARRAY 
(IDX) TO A

intraprogram An operation with array 
elements.
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cond IF A = B ... intraprogram Comparison of data items 
with a symmetric 
relationship.

cond* IF A * X = B 
... 

intraprogram Comparison of a multiple 
of a data item with 
another data item.

const cond IF A = 1 ... intraprogram Comparison of a data 
item with a constant.

const.move MOVE 1 TO 
B

intraprogram A constant moved into a 
data item.

const.comp ADD 1 TO B intraprogram An arithmetic operation 
with constants.

const.init 03 A ... 
VALUE 1

intraprogram A data item initialized by 
a constant.

DMS records N/A interprogram N/A For Unisys 2200 Cobol, 
data communication via 
Unisys DMS database 
records.

files N/A interprogram N/A Data communication via 
files. Traced only when 
corresponding JCL, ECL, 
FCT, or CSD files are 
verified. 

files in jobs N/A interprogram N/A Data flow in JCL datasets 
when files is selected.

input port N/A intraprogram A data item in which data 
is received. 

move MOVE A TO 
B

intraprogram A data item moved to a 
data item of the same 
type.

network 
records

N/A interprogram N/A For Unisys 2200 Cobol, 
data communication via 
network records.

output port N/A intraprogram A data item from which 
data is sent.

Relationship Definition Type Icon Description
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Assigning Business Names Manually

Describes how to assign business names manually.

To assign a business name and business description to an object, select the 
object and choose Set Business Attributes in the right-click menu. A dialog box 
opens, where you can enter the business name and business description. To 
unassign a business name or business description, simply delete the value in the 
dialog box.

Setting Global Data Flow User Preferences

Describes how to set Global Data Flow User Preferences.

Use the HyperView:Data View tab of the User Preferences window to specify 
the color-coding used in the Data View pane and the order of display of vari-
ables with the same offset. 

TASK

1. Choose Tools > User Preferences. The User Preferences window 
opens. Click the HyperView tab, then the Data View tab.

screens N/A interprogram N/A Data sent to a screen by 
one program and received 
in a screen by another.

screen 
definitions

N/A interprogram N/A Data flow in screen fields 
when screens is selected. 

start N/A intraprogram The startup item in an 
Impact pane consolidated 
analysis. 

used MOVE ... TO 
A ... MOVE A 
TO ...

intraprogram A value assigned in a 
statement used as an 
argument in another 
statement. 

Relationship Definition Type Icon Description
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2. In the Same offset order group box, specify the order you want vari-
ables with the same offset to be displayed in the Data View pane. 
Choose:
• Data item size if you want variables with the same offset to be 

displayed in size order, largest to smallest.

• Appearance in the source code if you want variables with the same 
offset to be displayed in the order they appear in the source code.

3. Click the arrow beside the drop-downs for Free Space Color, Used 
Space Color, and FILLER Color to specify the color of each item in the 
Data View pane.

4. Select Display Business Names to display business names for objects 
in the Data View pane.

Setting Global Data Flow Project Options

Describes how to set Global Data Flow Project Options.

Use the Global Data Flow tab of the Project Options window to specify whether 
data flow diagrams include literals, variable values set at initialization, and 
Unisys Cobol common storage variables; whether they show incoming, 
outgoing, and recursive data flows; and the number of nodes they display. 

TASK

1. Choose Tools > Project Options. The Project Options window opens. 
Click the Global Data Flow tab.

2. In the Relationships pane, choose any combination of:
• Literal Flow to include literals in the data flow diagram for the selected 

variable

• Initial Values to include variable values set at initialization in the data 
flow diagram for the selected variable.

• Common Area Transition to include Unisys Cobol common storage 
variables in the data flow diagram for the selected variable. Common 
storage variables are not explicitly declared in CALL statements.

NOTE:  To include Unisys Cobol common storage variables, you must have 
verified the project with the Perform Unisys Common-Storage Analysis 
option set in the project verification options. 
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3. In the Directions pane, choose any combination of:
• Causes to generate data flows into the selected variable.

• Consequences to generate data flows from the selected variable.

• Self-Dependencies to show recursive data flows for the selected vari-
able.

4. In the Node Limit combo box, enter the maximum number of diagram 
nodes you want to display. You might restrict the number of nodes to 
improve performance or make the diagram easier to read. You can also 
use the slider on the Node Limit tool bar to adjust the number of 
displayed nodes.

NOTE:  All children of a parent node are displayed even if some of them 
exceed the specified maximum.
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4
 Analyzing Batch
Applications
The Batch Application Viewer lets you perform low-level analysis of batch 
processes. Use the Batch Application Viewer’s rich set of tables and diagrams to 
determine if batch jobs are dependent on one another, the programs that use a 
data store, and the flow of data into or out of a data store. 

NOTE:  Batch Application Viewer analyzes JCL and ECL jobs. Usage is identical 
except for language-specific differences in terminology.

Understanding the Batch Application Viewer 
Window

Describes the Batch Application Viewer window.

Use the Batch Application Viewer to determine if batch jobs are dependent on 
one another, the programs that use a data store, and the flow of data into or out 
of a data store. To open Batch Application Viewer, select a project in the Repos-
itory Browser and choose Analyze > Batch Application. 

The Batch Application Viewer window displays job, procedure, and data set 
views of the batch application. Your selection in the current view, displayed in 
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the lefthand pane, filters the objects displayed in the other two views. Click the 
appropriate tab at the bottom of the window to make a view current. To 
generate a report for the current view in HTML, choose File > Report.

Use the  button and adjacent field on the toolbar to perform a standard 
HyperView search of the current view. In any view or diagram, select an object 
and click HyperView at the bottom of the window to view the object in Hyper-
View. 

You can hide a view by clicking the close box in the upper righthand corner. 
Select the appropriate choice in the View menu to show the view again. The 
figure below shows the Batch Application Viewer window.

Job View

Describes the Job View.

When the Job View is current, select a job to view the steps the job uses, the 
procedure or program each step executes, and the data stores each procedure or 
program reads from or writes to. 
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Procedure View

Describes the Procedure View.

When the Procedure/Program View is current, select a procedure or program 
to view the jobs and steps that execute it, and the data stores programs read from 
or write to. 

NOTE:  For programs executed by procedures, Batch Application Viewer displays 
data stores referenced by DD statements added after the substitution of the proce-
dure.

Dataset View

Describes the Dataset View.

When the Dataset View is current, select a dataset to view the procedure or 
program that reads from or writes to it, the step that executes the procedure or 
program, and the job that contains the step. 

To view the flow of data into or out of a dataset, select the dataset in the Dataset 
View and a step in the Procedure/Program View, then click the  button in the 
Data Set Flow pane. Click the  button in the Data Set Flow pane to view the 
flow of data into the dataset, click the  button to view the flow of data out of 
the dataset.

Generating Batch Application Diagrams

Describes how to generate Batch Application Diagrams.

Batch application diagrams show the relationships between jobs, programs or 
procedures, and data stores. The diagram uses Modernization Workbench 
common diagramming features. 

TASK

1. In the current view, mark the objects you want to diagram. 
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2. In the Diagram menu, choose the relationships you want to view in the 
diagram:
• Job Dependencies shows dependencies between jobs. Jobs are 

regarded as dependent if one writes to a dataset and the other reads 
from the same dataset.

• Data Set Usage shows interactions with datasets.

• JCL Procedures Usage shows interactions with procedures.

• Program Usage shows interactions with programs.

NOTE:  The menu choice is grayed out with a check mark beside it if the rela-
tionship must be displayed in the diagram. You can also set these choices 
after you display the diagram.

3. Click Diagram at the bottom of the Batch Application Viewer window. 

RESULT: The diagram is displayed in the Diagram View.

Assigning Business Names Manually

Describes how to assign business names manually.

To assign a business name and business description to an object, select the 
object and choose Set Business Attributes in the right-click menu. A dialog box 
opens, where you can enter the business name and business description. To 
unassign a business name or business description, simply delete the value in the 
dialog box.

Marking Items

Describes how to mark items.

To mark an item, place a check mark next to it. To mark all the items in the 
current view, choose Edit > Check All. To unmark all the items in the current 
view, choose Edit > Uncheck All.

 To mark selected items, select the items and choose Edit > Check Selected. To 
unmark selected items, choose Edit > Uncheck Selected.
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Creating Job Dependencies in Batch 
Application Diagrams

Provides an overview of job dependencies.

Batch Application Viewer treats jobs as dependent if one writes to a dataset and 
the other reads from the same dataset. Occasionally, you may want to define 
dependencies between jobs based on other criteria: administrative needs such as 
scheduling, for example. Batch Application Viewer modifies the diagram only, 
not the repository.

Defining Dependencies Between Jobs

Describes how to define job dependencies.

To define dependencies between jobs in a batch application diagram, hold down 
the Alt key, select either job, and drag-and-drop the relationship to the other 
job. The relationship is displayed in red with three plus (+) signs at either end 
of the relationship line.

Importing and Exporting Job Dependencies

Describes how to import and export job dependencies.

To import job dependencies from a file, choose File > Import Dependency 
Changes. A dialog opens, where you can specify the file you want to import. 

To export job dependencies to a file, choose File > Export Dependency 
Changes. A Save As dialog opens, where you can specify the name and location 
of the file.

Removing Job Dependencies

Describes how to remove user-defined job dependencies.

To remove all user-defined dependencies from a batch application diagram, 
choose File > Clean Up Dependencies. 

NOTE:  In certain circumstances (jobs that use cataloged file generation, for 
example), Batch Application Viewer may create false dependencies. You must 
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remove these relationships manually by right-clicking the dependency and 
choosing Remove from the pop-up menu.

Creating User Names for Objects in Batch 
Application Diagrams

Provides an overview of user names for objects in diagrams.

You can give diagram objects friendlier names, called user names. Batch Appli-
cation Viewer modifies the diagram only, not the repository.

NOTE:  To display user names in a diagram, select User Names in the Batch Appli-
cation Viewer workspace options.

Specifying User Names

Describes how to assign user names in batch application diagrams.

To specify a user name for an object in a batch application diagram, select the 
object and choose View > User Name. The User Name dialog opens, where you 
can specify the user name.

Importing and Exporting User Names

Describes how to import and export user names for batch application diagrams.

To import user names from a file, choose File > Import User Names. A dialog 
opens, where you can specify the file you want to import. 

To export juser names to a file, choose File > Export User Names. A Save As 
dialog opens, where you can specify the name and location of the file.

Removing User Names

Describes how to remove user names from batch application diagrams.

To remove all user names from a batch application diagram, choose File > 
Clean Up User Names.
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Setting Batch Application Viewer Options

Describes how to set Batch Application Viewer Options.

Use the Batch Application Viewer tab of the Workspace Options window to 
specify the color-coding used for relationship lines in batch application 
diagrams. Diagram objects are color-coded based on the color scheme in the 
Diagrams User Preferences. 

TASK

1. Choose Tools > Workspace Options. The Workspace Options window 
opens. Click the Batch Application Viewer tab.

2. In the Diagram Relations pane, click the relationship type whose color 
you want to specify, then specify the color in the Edge Color 
drop-down.

3. To display user names in a diagram, select User Names.

4. In the Node Limit combo box, enter the maximum number of diagram 
nodes you want to display. You might restrict the number of nodes to 
improve performance or make the diagram easier to read. You can also 
use the slider on the Node Limit tool bar to adjust the number of 
displayed nodes.

NOTE:  All children of a parent node are displayed even if some of them 
exceed the specified maximum.
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5
 Estimating Complexity
and Effort
Modernization Workbench Legacy Estimation tools let you compare programs 
based on weighted values for selected complexity metrics. The metrics used in 
the calculation are a combination of industry standard and Modernization 
Workbench-generated statistics. Based on the comparison, you can develop a 
credible estimate of the time required to satisfy a change request or perform 
other maintenance tasks. 

NOTE:  For definitions of the supported complexity metrics, see the support guide 
for the programming language in use in your application.

Viewing Complexity Metrics

Describes the Complexity Metrics tool.

Use the Complexity Metrics report to compare raw complexity values for the 
objects in your project. To open the Complexity Metrics report, select a project 
in the Repository Browser and choose Analyze > Complexity. 

When the Complexity Metrics window opens, choose the type of object you 
want to compare in the Entity Type drop-down. To generate the report in 
HTML, choose File > Report. The figure below shows the Complexity Metrics 
window. 
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Setting Complexity Metrics User Preferences

Describes how to set Complexity Metrics User Preferences.

Use the Complexity Metrics tab of the User Preferences window to specify the 
metrics displayed in the Complexity Metrics report for each type of object in 
your application. 

TASK

1. Choose Tools > User Preferences. The User Preferences window 
opens. Click the Complexity Metrics tab.

2. In the Source Type drop-down, select the type of object you want to 
display complexity metrics for. 

3. In the Attributes pane, select each complexity metric you want to be 
displayed for the selected object type.
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Estimating Effort

Describes the Effort Estimation tool.

Use the Effort Estimation tool to compare source files based on weighted values 
for selected complexity metrics. To open the Effort Estimation tool, select a 
project in the Repository Browser and choose Analyze > Effort. 

Select the source files types to be included in the calculation and the weighted 
values for the metrics in the Effort Estimation options. When you are satisfied 
with your selections, choose File > Compute Effort. 

When the effort estimation report is displayed, select a source file in the Effort 
pane to show the effort statistics for its generated objects in the Details pane and 
the HyperView information for the file in the Preview pane. To generate the 
report in HTML, choose File > Report. The figure below shows the Effort Esti-
mation window.
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Setting Effort Estimation Options

Describes how to set Effort Estimation Options. 

Use the Effort Estimation tab of the Project Options window to specify the file 
types included in the effort estimation calculation and the complexity metrics 
for each type. These options also control the percentage factor for the change 
magnitudes used in the calculation. 

TASK

1. Choose Tools > Project Options. The Project Options window opens. 
Click the Effort Estimation tab. 

2. In the Factors pane, select each source file type you want to include in 
the calculation. 

3. For each source file type selected in the Factors pane, click Attributes 
to edit the complexity metrics used in the calculation. 

4. In the Attributes window, select each complexity metric you want to 
use in the calculation, then enter its weight in the Weighting Factor 
field. For example, if you want Cyclomatic Complexity to have twice the 
weight of Conditional Complexity, set the weighting factor for Cyclo-
matic Complexity to 2 and the weighting factor for Conditional 
Complexity to 1. 

5. To set the percentage factor for the change magnitudes used in the 
calculation, enter the percentage you want to be applied in the combo 
box for each change magnitude. 

Specifying the Change Magnitude for a Source 
File

Describes how to specify a change magnitude for a source file.

Suppose you are planning to implement a change request and want to know 
how long it will take to complete the change. In that situation, you typically run 
an effort estimation report for your project based on weighted values for 
selected complexity metrics. 
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But what if your own analysis of the project shows that a given program will 
actually take much less time to change than the weighted calculation would 
suggest. The program might have thousands of source lines, for example, 
increasing its calculated complexity, while actually being very easy to modify. 

A change magnitude is a way of overriding the calculated value for a source file. 
Your "subjective" estimate of the effort involved, Small, Medium, Large, Extra 
Large, becomes an input to the effort calculation, along with the weighted 
values. 

You can specify a change magnitude in the HyperView Source or Context pane, 
or in the Effort Estimation tool itself. Select the source file and choose Set 
Change Magnitude in the right-click menu. Set the change magnitude to S for 
Small, M for Medium, L for Large, or XL for Extra Large. The effort estimation 
calculation for the selected file is automatically updated.
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6
 Identifying Classes of
Data Items
Change Analyzer identifies the class of data items used to perform a business 
function in a legacy application. Among other uses, it lets you answer the kinds 
of “What if?” questions posed in the past by industry-wide changes for Y2K, 
Zip+4, and the Euro dollar: “What if I change the type of this variable, or the 
length of this field? What other fields in the class will I also have to change?” 

For each field in the class, you can use Change Analyzer to perform an impact 
trace that shows the flow of data to the field, and to detect and resolve program 
ports. You can generate reports showing source entities that may require modi-
fication, lines of affected code, and the like. 

NOTE:  Projects must have been verified with the Enable Data Element Flow 
option set in the Project Verification options. Project options on the Impact > 
Relationships tab control the relationships detected during synonym and impact 
trace processing. 

Understanding Data Item Classification

Offers background on data item classification. 

Suppose your organization is considering adding support for a new currency 
and that you are going to have to expand the existing exchange rate data field 
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from 9(5)V9(3) to 9(5)V9(6) to accommodate the currency. You will need to 
know the data fields that are affected in the database, intermediate fields that 
may contain or use the exchange rate field in calculations, and so forth. 

Seed Fields

Use Change Analyzer to search for the exchange rate field. The object of the 
search is called a seed field: 

• If the application uses field names like EX-RATE, EXCH-RATE, 
EXCHANGE-RATE, and RATE-OF-EXCHG, you would search for data 
names that contain *EXCH* or *RATE*. 

• If you know that some fields already contain the required number of 
decimal positions and are interested only in those that don’t, you might 
further limit the search by filtering on the PICTURE clause format of the 
variable, selecting only data items that have a format of 9(5)V9(3). 

• You might limit the search even further by choosing fields that have a 
given initial value. 

• If you know there are data fields that will meet the search criteria for name, 
but are not what you are looking for, you might set up a list of names to 
exclude, such as INTEREST-RATE and *PRORATE*. 

Synonyms

Once you have found the exchange rate field, you can use Change Analyzer to 
detect its synonyms. A synonym is a data field whose value is related to the value 
of a seed field: a field whose value is assigned by a MOVE or REDEFINE state-
ment, for example. In these cases, if you increase the size of the seed field, you 
probably will need to increase the size of its synonyms as well. 

Analyzing Seed Fields and Synonyms

Not every seed field or synonym will be affected by a proposed change. You 
need to examine the source code for each instance of the field carefully in the 
Change Analyzer Source pane and in the HyperView tools accessible from the 
Source pane. You may want to perform an impact trace showing the flow of data 
to the field as documentation, or to ensure that you have accounted for each 
instance. 
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Seed Lists

Once you determine which fields are affected by a proposed change, you can 
move the fields between seed lists: Working and Affected, for example. You can 
generate reports based on your lists, as well as reports showing the affected 
source code in context. 

Getting Started in Change Analyzer

Provides an example of Change Analyzer usage. 

This section describes a sample use of Change Analyzer that should help you get 
oriented in the tool. Assume that you want to evaluate the impact of changing 
the YEAR field in your application. 

TASK

1. In the Repository Browser, select the project you want to analyze and 
choose Analyze > Change Analyzer. 

2. The Change Analyzer window opens. Click in the Lists pane and choose 
Add List in the right-click menu. Change Analyzer creates a list named 
New List 1. Select New List 1 and choose Rename List in the right-click 
menu. In the Rename List dialog, enter Working in the New Name field 
and click OK. Follow the same procedure to create another list named 
Affected. 

3. Choose File > Apply Filter > Add Items. The Select List dialog opens. 
Select the Working list and click Select. 

4. The Search window opens. Click the Change Analyzer tab to view a list 
of recognized search criteria. Click the  button on the tool bar to 
define a new criterion. In the New Search Criterion dialog, enter YEAR 
and click OK. The YEAR criterion is displayed in the list of recognized 
criteria in the Change Analyzer tab in the Search window. 

5. In the Change Analyzer tab, select the YEAR criterion, enter the search 
text for the criterion in the Name Like tab, and click Find All Constructs. 
Change Analyzer returns the seed fields for the criterion in the Working 
list. 

6.  Select a program in the Programs pane to view its seed fields in the 
Working list. Select a seed field to navigate to its declaration in the 
Source pane. Examine the declaration to determine whether the field 
will be affected by the proposed change. 
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NOTE:  Click Show list items for all files to display the seed fields for all the 
files in the project. 

7. In the Working list, select each field that will be affected by the change 
and choose Edit > Move. The Move/Copy List Items dialog opens. In the 
Select Method drop-down, select Move. In the To List: pane, select the 
Affected list and click OK. Change Analyzer moves the fields to the 
Affected list. 

8. Select a seed field in the Affected list and choose Find Synonyms in the 
right-click menu. The Find Synonyms dialog opens. Specify the depth of 
synonym processing in the Depth combo box, then click OK. Change 
Analyzer displays the synonyms for the selected field on the Synonyms 
tab in the Synonyms and Ports pane. 

9. Examine the declaration for each synonym to determine whether the 
field will be affected by the proposed change. Use the procedure 
described above to move the affected fields to the Affected list. Find 
synonyms for these fields the same way you found synonyms for seed 
fields. 

10. Choose File > Reports. The Report Selection dialog opens. In the 
Report Type drop-down, select Report on Lists. In the Select List pane, 
select the Affected list and click Generate Report. Change Analyzer 
displays the report for the Affected list. 

Understanding the Change Analyzer Window

Provides an overview of the Change Analyzer window. 

Use the Change Analyzer to identify classes of data items. To open the Change 
Analyzer, select a project in the Repository Browser and choose Analyze > 
Change Analyzer. 

The figure below shows the Change Analyzer window after searching for seed 
fields, detecting synonyms, and moving items between lists. The current 
contents of Change Analyzer lists are stored in the Change Analyzer folder in 
Clipper. 
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Programs Pane

Describes the Change Analyzer Programs pane. 

The Programs pane displays the programs in the selected project. Select a 
program to view its seed fields in the List pane. 
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Lists Pane

Describes the Change Analyzer List pane. 

The Lists pane displays the lists for the project. The number in parentheses after 
the list name indicates the number of items the list contains for the selected 
program. Click Show list items for all files to display the items for all the files 
in the project. 

Click the appropriate tab to view a list. Select a field to navigate to its declaration 
in the Source pane. 

The table below describes the columns in the Lists pane. You can filter a column 
by clicking an item in the  drop-down for the column. 

TIP:  The Comment column is especially useful for filtering lists. 

Creating Lists

Describes how to create lists. 

To create a list, click in the tool bar of the Lists pane and choose Add List in the 
right-click menu. Change Analyzer creates a list named New List n. 

To rename the list, select it and choose Rename List in the right-click menu. In 
the Rename List dialog, enter the name of the list in the New Name field and 
click OK. 

Column Description 

Name The name of the field. 

Length The length of the field. 

Value The value of the field. 

Picture The format of the field. 

Normalized Picture The normalized picture of the field. 

Comment The comment for the field. 

Program The program in which the field is used. 

File The source file that contains the declaration for the 
field. 
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Deleting Lists

Describes how to delete lists. 

To delete a list, select it and choose Remove List in the right-click menu. You 
are prompted to confirm that you want to delete the list. Click Yes. 

Selecting Items

Describes how to select fields in lists. 

Click an item to select it. Use Ctrl-click to select multiple items. Use Shift-click 
to select a range of items. To select all the items on a list, click the tab for the list 
and choose Edit > Select All. 

Editing the Comment for a Field

Describes how to edit the comment for a field. 

To edit the comment for an item, select the item and choose Edit > Comment. 
A dialog opens where you can edit the comment. 

Moving Fields Between Lists

Describes how to move fields between lists. 

To move fields between lists, select the fields, then choose Edit > Move to. The 
Move/Copy List Items dialog opens. In the Select Method drop-down, select 
Move to move the selected fields or Copy to copy the fields. In the To List: pane, 
select the target list and click OK. 

Performing Set Operations with Lists

Describes how to perform set operations with lists. 

To join lists using AND or OR operations, or to subtract the contents of one list 
from another, choose Edit > Set Operations. The List Set Operations dialog 
opens. In the Left pane, select the list on the left side of the set operation. In the 
Right pane, select the list on the right side of the set operation. In the Destina-
tion pane, select the target list. Select the operation you want to perform in the 
Choose Operation drop-down and click OK. 
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Deleting Fields

Describes how to delete fields from lists. 

To delete a field, select it and choose Edit > Delete. 

Synonyms and Ports Pane

Describes the Change Analyzer Synonyms and Ports pane. 

The Synonyms and Ports pane displays two tabs: 

• The Synonyms tab displays the synonyms or impact trace for the field 
selected in the Lists pane. Select a synonym to navigate to its declaration 
in the Source pane. Select a field in an impact trace to navigate to its use in 
the Source pane. 

• The Ports tab displays the field selected in the List pane if Change 
Analyzer has detected a port in which the field is used. Select the field to 
navigate to the port in the Source pane. 

Click the appropriate tab to view an item. The table below describes the columns 
in the Synonyms and Ports pane. 

Column Description 

Name The name of the field. 

Length The length of the field. 

Value The value of the field. 

Picture The format of the field. 

Normalized Picture The normalized picture of the field. 

Comment The comment for the field. 

NOTE:  The comment reads "Port found" on the Ports 
tabs when a port has been detected. 

Program The program in which the field is used. 

File The source file that contains the declaration for the 
field. 
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Source Pane

Describes the Change Analyzer Source pane. 

The Source pane lets you browse the source code for the selected program and 
the declaration for the selected field or synonym. When an impact trace is 
displayed in the Synonyms tab, select a field in the trace to navigate to its use in 
the Source pane. When a field is listed on the Ports tab, select the field to navi-
gate to the port in which the field is used. 

Usage is similar to that for the Source pane in HyperView. For HyperView usage 
information, see Analyzing Programs in the workbench documentation set. 

Searching for Seed Fields in Change Analyzer

Describes how to search for seed fields in Change Analyzer. 

The Change Analyzer search facility contains two tabs: 

• The General tab opens the HyperView advanced search facility. 

• The Change Analyzer tab opens a scoped version of the advanced search 
facility for Change Analyzer. 

Ordinarily, the scoped version of the tool should be sufficient for most searches. 
If you are already familiar with the advanced search facility, however, you may 
want to use it instead of the scoped tool. 

NOTE:  For Cobol programs, Change Analyzer returns only constants and literals 
found in the Procedure section. 

TASK

1. Choose File > Apply Filter> Add Items. The Select List dialog opens. 
Select the list for seed fields and click Select. 

2. The Change Analyzer Search window opens. Click the Change Analyzer 
tab. The Change Analyzer tab displays a list of recognized search 
criteria. 

NOTE:  Define a new criterion as described in the help for the advanced 
search facility. 

3. Select a criterion to edit its definition in the tabs in the righthand 
portion of the window. Each tab specifies a condition in the definition. 
The definition can consist of any combination of conditions. 
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4. For each condition, enter a list of patterns you want to match, one 
pattern per line. You can use wildcard patterns allowed in LIKE state-
ments by Visual Basic for Applications (VBA). Select: 
• Name Like to specify patterns that are like the name of the field you are 

searching for. 

• Name Not Like to specify patterns that are unlike the name of the field 
you are searching for. 

• Picture Like to specify patterns that are like the format of the field you 
are searching for. 

• Value Like to specify patterns that are like the initial value of the field 
you are searching for. 

5. Select Use OR Connection Between Lists if you want the conditions 
defined in the tabs to be ORed. If you do not select this option, the 
conditions are ANDed. 

6. Select Used Data Items Only if you want the search results to consist 
only of fields that are used in the selected programs. If you do not select 
this option, search results include fields that are declared but not used. 

7. In the Search In drop-down on the tool bar, choose: 
• All Objects if you want to execute the search against all the source files 

in the project. 

• A Clipper list if you want to execute the search only against the source 
files on the list. 

8. Click Find All Constructs to execute the search. 

RESULT: Change Analyzer returns the seed fields for the criterion in the selected 
list. The results are added to any previous results. 

Detecting Synonyms

Describes how to detect synonyms for seed fields. 

To detect the synonyms for seed fields, select the fields in the Lists pane and 
choose Find Synonyms in the right-click menu. The Find Synonyms dialog 
opens. Specify the depth of synonym processing in the Depth combo box, then 
click OK. Change Analyzer displays the synonyms for the selected fields on the 
Synonyms tab in the Synonyms and Ports pane. 
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Batch-Detecting Synonyms

Describes how to batch-detect synonyms for seed fields. 

Follow the instructions below to batch-detect synonyms and add the synonyms 
to a list. 

TASK

1. Choose File > Find Synonyms. The Find Synonyms dialog opens. 

2. In the Find In pane, select the list of seed fields whose synonyms you 
want to find. In the Add Synonyms To pane, select the list to which you 
want to add the synonyms. 

TIP:  The lists may and often will be the same. To create a new list, enter the 
name of the list in the New List field and click Create List. 

3. Specify the depth of synonym processing in the Depth combo box. 

4. Click OK. 

RESULT: Change Analyzer adds the synonyms to the target list. 

Performing an Impact Trace

Describes how to perform an impact trace for a seed field. 

 The impact trace for a seed field displays the flow of data to the field: how data 
items exchange values, use each other in computations, and so forth. Perform 
an impact trace when you want to document your analysis, or to ensure that you 
have accounted for each instance of a field. 

To perform an impact trace for a seed field, select the seed field in the Lists pane 
and choose Find Synonyms in the right-click menu. The Find Synonyms dialog 
opens. Click Show Impacts, then specify the depth of the trace in the Depth 
combo box. Click OK. Change Analyzer displays the impact trace for the 
selected field on the Synonyms tab in the Synonyms and Ports pane. 
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Viewing and Resolving Ports

Describes how to view and resolve ports. 

When Change Analyzer detects synonyms for a seed field, it also detects any 
ports in which the seed field is used. It displays the declaration for the port in 
the Ports tab with the comment "Port found" along with the Hyperview infor-
mation for the port. Select the declaration to navigate to the port in the Source 
pane. 

Resolving a port identifies the port with which the detected port communicates. 
By tracking communications between ports, you can analyze affected fields 
across programs. Follow the instructions below to resolve a port. 

TASK

1. In the Ports pane, select the declarations for the ports you want to 
resolve and choose Resolve Ports in the right-click menu. The Resolve 
Ports dialog opens. 

2. Select the list to which you want the declarations for the communi-
cating ports to be added. 

TIP:  To create a new list, enter the name of the list in the New List field and 
click Add List. 

3. Click OK. 

RESULT: Change Analyzer adds the declarations for the communicating ports to 
the target list. 

Creating Projects in Change Analyzer

Describes how to create projects in Change Analyzer. 

You can create a project directly in Change Analyzer from the results of your 
analysis. The project contains only source files with fields in the selected list. 

TASK

1. Select a list and choose Create Project in the right-click menu. 
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2. The New Project dialog opens. Enter the name of the new project in the 
text field and click OK. 

3. The Change Magnitude window opens. Select Automatically calcu-
late change magnitude if you want Change Analyzer to set change 
magnitudes for the listed source files based on the ranges specified in 
the fields below the check box. The Change Analyzer settings will over-
ride any existing change magnitudes for the files. 

Setting Change Analyzer Options

Describes how to set Change Analyzer project options. 

Use the Change Analyzer tab of the Project Options window to specify the 
default depth of synonym and impact trace processing and the amount of infor-
mation to display in the Affected Code report. 

TASK

1. Choose Tools > Project Options . The Project Options window opens. 
Click the Change Analyzer tab. 

2. In the Synonyms pane, specify the depth of synonym and impact trace 
processing in the Default Depth combo box. Click Show Impacts 
Default Setting if you want to display the default setting in the Change 
Analyzer dialog boxes you use to detect synonyms and perform impact 
traces. 

TIP:  You can override the default depth setting in these dialog boxes. 

3. In the Affected Code Report pane, specify in the Neighborhood Size 
combo box the number of lines of unaffected code you want the 
Affected Code report to display above and below the line of affected 
code. (The line of affected code is displayed in bold in the report.) 
Choose Show unused datanames if you want the report to include 
unused data fields. 
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Generating Change Analyzer Reports

Describes how to generate Change Analyzer reports. 

To generate HTML reports in Change Analyzer, choose File > Reports. The 
Report Selection dialog opens. In the Report Type drop-down, select the report 
type. For a list report, select the list to report on in the Select List pane. Click 
Generate Report. Change Analyzer displays the report. 
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7
 Repository Exchange
Protocol Syntax
The Repository Exchange Protocol (RXP) is an XML-based API that you can 
use to interact with application-level information in the workspace repository. 
This chapter describes the RXP query syntax and provides examples of its use.

Query Syntax

Describes RXP syntax.

An RXP query consists of the tags and attributes described in this section.

Query

<query [name='QueryName']> { Object } </query>

Objects

<object [global='false']>
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[ <objecttype> ObjectTypeCondition </objecttype> ]
[ <cond> Condition </cond> ]
[ <fetchtype as='FieldName'/> ]
[ <fetchid as='FieldName'/> ]
[ <fetchdisplay as='FieldName'/> ]
[ <fetchorigin as='FieldName'/> ]
[ <fetchsource as='FieldName'/> ]
[ <fetchsize as='FieldName'/> ]
{ <fetchconst type='FieldType' value='Constant'
as='FieldName'/> }
{ <fetchattr attr='AttrName' as='FieldName'/> }
[ <related [countas='FieldName'][optional='true']>
RelatedSpec
</related>]
</object>

ObjectTypeCondition

<typeset flag='FlagName' [negate='true']/>
| <type name='EntityName' [negate='true']/>
| <and [negate='true']> { ObjectTypeCondition }
</and>
| <or [negate='true']> { ObjectTypeCondition }
</or>

RelatedSpec

[ <reltype> RelTypeCondition </reltype> ]
[ <cond> Condition </cond> ]
[ <fetchtype as='FieldName'/> ]
{ <fetchattr attr='AttrName' as='FieldName'/> }
Object

RelTypeCondition

<relset flag='RelFlagName' [negate='true']
[incoming='true']/>
| <rel name='RelationName' [negate='true']/>
| <and [negate='true']> { RelTypeCondition } </and>
| <or [negate='true']> { RelTypeCondition } </or>
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Condition

<attr name='AttrName' op='Operation'
arg='Argument' [negate='true']/>
| <hasrelated [negate='true']> RelatedSpec
</hasrelated>
| <id equals='Integer' [negate='true']/>
| <id in='Integer{,Integer}' [negate='true']/>
| <source equals='String' [negate='true']/>
| <source in='String{,String}' [negate='true']/>
| <origin equals='SID' [negate='true']/>
| <origin in='SID{,SID}' [negate='true']/>
| <and [negate='true']> { Condition } </and>
| <or [negate='true']> { Condition } </or>

EntityName

The name of a repository entity.

AttrName

The name of an entity attribute.

FieldName

The field name of the returned record set.

Operation

 = | <> | > | >= | < | <= | like | in | between

FlagName

LEGACY | PROGRAMCODE | SYSTEM | KNOWLEDGE | GENERATED | 
EXTRACT | COMPOSITE
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RelFlagName

REFER | USE | GENERATE | PRODUCE

RelationName

The name of a relationship.

Argument

The argument to the operation. Depends on both argument type and operation.

QueryName

A string.

Example 1

Provides an RXP usage example.

This example queries the repository for the object ID and parse status of the 
GSS.cbl source file:

<query name="Select a COBOL object by name"> 
  <object> 
    <objecttype> 
      <type name="COBOL"/> 
    </objecttype> 
    <fetchid as="ID"/> 
      <fetchattr name="ParseStatus" as="Parsed"/> 
    <cond> 
      <attr name="Name" op="=" arg="GSS.cbl"/> 
    </cond> 
  </object> 
</query> 
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Example 2

Provides an RXP usage example.

This example queries the repository for copybooks used in three Cobol 
programs:

<query name="Find COPYBOOKs used in given programs">
  <object>
    <objecttype>
      <type name="COBOL"/>
    </objecttype>
    <cond>
      <attr name="Name" op="in"
       arg="'GSS1.CBL','GSS2.CBL','GSS3.CBL'"/>
    </cond>
    <related>
      <reltype>
        <relset flag="USE"/>
      </reltype>
      <object>
        <fetchid as="ID2"/>
        <fetchtype as="ObjectType2"/>
        <fetchdisplay as="ObjectName2"/>
      </object>
    </related>
  </object>
</query>
83



REPOSITORY EXCHANGE PROTOCOL SYNTAX
EXAMPLE 2
 84



 

8
 Common Diagramming
Features
This chapter describes features shared by many of the workbench diagramming 
tools (although not the Diagrammer itself). Use these features to edit diagrams, 
save diagrams in standard formats, print diagrams, and more.

Zooming

Describes how to zoom in the common diagrammer.

Use the slider  on the tool bar in the lower lefthand corner of 
the tool window to zoom in or out on a diagram. Click the  button on the tool 
bar to restore the 100% zoom level.

Printing Diagrams

Describes how to print from the common diagrammer.

Click the  button on the tool bar in the lower lefthand corner of the tool 
window to print the diagram. The Print Preview window opens, where you can 
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change the zoom factor for the diagram to control the number of pages in the 
print job.

Saving Diagrams

Describes how to save diagrams in the common diagrammer.

Click the  button on the tool bar in the lower lefthand corner of the tool 
window to save a diagram to BED, bitmap, JPEG, Visio, Visio XML, DOT, or 
EMF.

NOTE:  Visio 2002 must be installed to save a diagram to Visio. Visio 2002 is not 
required to save to Visio XML. 

Copying Diagrams

Describes how to copy diagrams in the common diagrammer.

Click the  button on the tool bar in the lower lefthand corner of the tool 
window to copy the diagram to the clipboard in EMF format. You can paste the 
diagram from the clipboard to a document in a third-party tool such as Word.

Performing Basic Tasks in the Diagram Editor

Describes how to perform basic editing tasks in the common diagrammer.

Use the built-in Diagram Editor to edit diagrams, change the appearance of 
diagrams, cut-and-paste from a diagram, and other tasks. 
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Opening a Diagram in the Diagram Editor

Click the  button on the tool bar in the lower lefthand corner of a diagram-
ming tool window. The diagram on view in the tool opens in the Diagram 
Editor.

Creating a Diagram in the Diagram Editor

To create a new blank diagram, choose File > New Diagram.

Using the Locate Facility

Use the Locate facility to navigate to general locations in a diagram. To invoke 
the Locate facility, click View > Locate. The Locate window opens.

The Locate window displays the entire diagram on view in the Diagram Editor 
main window. A frame surrounds the portion of the diagram visible in the main 
window. 

Drag the frame to the area of the diagram you want to view. The Diagram Editor 
displays the selected area in the main window.

Using the Quick Search Facility

Use the Quick Search facility to navigate to objects in a diagram. To invoke 
Quick Search, choose View > Search pane. The Quick Search facility opens at 
the top of the window. 

Enter the text for the search in the Quick Search field. You can use wildcard 
patterns allowed in LIKE statements by Visual Basic for Applications (VBA).

Using the Search and Replace Facility

Use the Search and Replace facility to modify captions or tool tips globally. The 
Diagram Editor modifies the diagram only, not the repository. 

To use the search and replace facility, choose Edit > Replace. The Replace 
window opens. Enter the text you want to replace in the Find field. Enter the 
text you want to substitute in the Replace field. Select Match case if you want to 
match the case of the entered text.You can apply the change to any combination 
of object captions, relationship captions, or tool tips by selecting the appropriate 
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choices in the Apply to pane. If you apply the change to object captions, select 
the appropriate choice in the Scope pane to apply the change to all the objects 
that contain the text or only the selected objects that contain the text.Click 
Replace to run the operation and dismiss the Replace window.

Selecting Objects in the Diagram Editor

Select an object or relationship in the Diagram Editor by clicking it. Deselect an 
object by clicking on white space or selecting another object. To select all the 
objects in the diagram, choose Edit > Select All. 

To select a range of objects, click in the diagram, hold down the right mouse 
button, drag the selection box over the objects you want to select, and release the 
mouse button. To select objects that are not in a range, hold down the Control 
key, then click each object you want to select.
 88


	Contents
	Managing Tags
	Understanding the Tag Manager Window
	Object List Pane
	Category Pane
	Projects Pane
	Object Types Pane
	Search Pane
	Query Pane
	Tags Pane

	Creating Tags
	Specifying Access to Tags
	Assigning Tags
	Removing Tags
	Creating Relationships Between Tags
	Deleting Tags
	Creating Tag Queries
	Deleting Tag Queries
	Refreshing the Tag Manager Window
	Cleaning Up the Tag Manager Window
	Generating Reports

	Analyzing Relationship Flows
	Understanding Relationship Flow Diagrams
	Understanding Diagram Scopes
	Understanding Diagram Layouts
	Generating a Diagram for the Selected Project
	Generating a Diagram for Objects Copied and Pasted onto the Canvas
	Understanding the Diagrammer Window
	Diagram Pane
	Selecting an Object or Relationship
	Searching for an Object
	Navigating to an Object from a Relationship
	Expanding and Collapsing Relationships
	Moving an Object or Relationship
	Resizing an Object
	Hiding an Object
	Deleting an Object or Relationship
	Assigning Tags
	Assigning Business Names
	Displaying Labels for Multiple Relationships
	Hiding Relationship Labels
	Displaying the Legend for a Diagram
	Zooming
	Moving a Diagram
	Clearing a Diagram

	Browser Pane
	Relationships Pane
	Quick View Pane
	Overview Pane

	Excluding Objects Outside the Project
	Showing Incomplete Composite Relationships
	Colorizing Project Boundaries
	Showing and Hiding Object Labels
	Working with Groups
	Grouping and Ungrouping Objects
	Expanding and Collapsing Groups
	Moving Objects Between Groups
	Naming Groups
	Deleting Groups

	Black-Boxing Tagged Objects
	Filtering Objects
	Setting Filter Overrides

	Clustering Objects
	Creating Clusters Manually
	Generating Tags from Clusters
	Setting Clustering Factors

	Setting Diagrams User Preferences
	Using the Scope Editor
	Understanding the Lefthand Pane of the Scope Editor
	Understanding the Righthand Pane of the Scope Editor
	Managing Scopes
	Hiding a Scope in the Scope Dropdown
	Displaying Only the Relationships Used in a Scope
	Hiding Empty Relationships
	Viewing a Diagram of a Scope
	Viewing a Diagram of a Composite Relationship
	Creating a Scope
	Specifying the Relationships in a Scope
	Editing Scope Details
	Copying a Scope
	Deleting a Scope
	Deleting a Composite Relationship
	Importing and Exporting Scopes
	Hiding Columns in the Scope Editor

	Creating Custom Composite Relationships
	Defining a Relationship Filter

	Pruning a Scope
	Mirroring a Scope

	Analyzing Global Data Flows
	Understanding the Global Data Flow Window
	Data View Pane
	Data Flow Pane
	Origin Pane

	Data Flow Relationships
	Assigning Business Names Manually
	Setting Global Data Flow User Preferences
	Setting Global Data Flow Project Options

	Analyzing Batch Applications
	Understanding the Batch Application Viewer Window
	Job View
	Procedure View
	Dataset View

	Generating Batch Application Diagrams
	Assigning Business Names Manually
	Marking Items
	Creating Job Dependencies in Batch Application Diagrams
	Defining Dependencies Between Jobs
	Importing and Exporting Job Dependencies
	Removing Job Dependencies

	Creating User Names for Objects in Batch Application Diagrams
	Specifying User Names
	Importing and Exporting User Names
	Removing User Names

	Setting Batch Application Viewer Options

	Estimating Complexity and Effort
	Viewing Complexity Metrics
	Setting Complexity Metrics User Preferences
	Estimating Effort
	Setting Effort Estimation Options
	Specifying the Change Magnitude for a Source File

	Identifying Classes of Data Items
	Understanding Data Item Classification
	Seed Fields
	Synonyms
	Analyzing Seed Fields and Synonyms
	Seed Lists

	Getting Started in Change Analyzer
	Understanding the Change Analyzer Window
	Programs Pane
	Lists Pane
	Creating Lists
	Deleting Lists
	Selecting Items
	Editing the Comment for a Field
	Moving Fields Between Lists
	Performing Set Operations with Lists
	Deleting Fields

	Synonyms and Ports Pane
	Source Pane

	Searching for Seed Fields in Change Analyzer
	Detecting Synonyms
	Batch-Detecting Synonyms
	Performing an Impact Trace
	Viewing and Resolving Ports
	Creating Projects in Change Analyzer
	Setting Change Analyzer Options
	Generating Change Analyzer Reports

	Repository Exchange Protocol Syntax
	Query Syntax
	Query
	Objects
	ObjectTypeCondition
	RelatedSpec
	RelTypeCondition
	Condition
	EntityName
	AttrName
	FieldName
	Operation
	FlagName
	RelFlagName
	RelationName
	Argument
	QueryName

	Example 1
	Example 2

	Common Diagramming Features
	Zooming
	Printing Diagrams
	Saving Diagrams
	Copying Diagrams
	Performing Basic Tasks in the Diagram Editor
	Opening a Diagram in the Diagram Editor
	Creating a Diagram in the Diagram Editor
	Using the Locate Facility
	Using the Quick Search Facility
	Using the Search and Replace Facility
	Selecting Objects in the Diagram Editor



