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Introduction

Optimal Trace Overview

Optimal Trace is a requirements capture, documentation and modeling suite for teams of Business
Analysts, Systems Analysts, Software Architects/Designers, QA Leads, QA Testers, and Project
Managers. It provides an easy to deploy, intuitive interface for capturing, viewing, and managing
customer requirements and a sophisticated collaboration mechanism that enables multiple
analysts to work concurrently on one or more projects.

There are two versions of Optimal Trace:

* Optimal Trace Enterprise. This is a fully functional version for multiple users that use the
benefits of a server. The Optimal Trace Enterprise Server component provides access to a
centralized repository of projects and manages communication between multiple users. A
computer that hosts the server software is referred to as a repository server. The Optimal
Trace Enterprise Server controls access to the database, manages concurrent editing of
projects by multiple users, and ensures the integrity of data being written to the database. If
you wish to make use of the collaboration features, you will need at least one repository
server on the network. Optimal Trace Enterprise Server requires a dedicated server machine
on the network to act as the repository server. This machine should be connected to the
network and should be accessible from every workstation on which you will be running
Optimal Trace Enterprise. Optimal Trace Enterprise Server connects to a database running
locally on the repository server or on another machine available on the network.

* Optimal Trace Professional. This is a streamlined version of Optimal Trace Enterprise and
works from the desktop.

Optimal Trace Administrator is installed as part of both the Optimal Trace Enterprise Server
and Optimal Trace Enterprise installations. This tool provides a highly flexible approach to
access control allowing permissions to be set for groups of users and individual users on given
projects and project baselines. This ensures that project stakeholders are allowed access and
editing capability on appropriate areas of the project or baseline.

Some common usage scenarios include:
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* Allowing project stakeholders such as Business Analysts/Engineering to have visibility into
a project.

* Allowing the QA team to edit the Test Requirements project but have 'read-only' access to
the Business Requirements.

* Restricting Engineering teams to editing certain packages and groups of requirements.

* Locking down reference projects for use throughout the organization.

* Locking down a project's Glossary, backups, baselines, and restricting access to sensitive

projects.

Specific product functionality includes:
* The ability to security-enable specific projects and baselines.

* The ability to create Groups, Users and Permissions for specific Projects, Packages, the
Project Glossary and Custom Properties for different parts of a project.

* The ability to configure certain users as Optimal Trace Administrators.
* The ability to use the same User Group structures for multiple projects.

* The ability to work offline and merge projects back to the repository, obeying appropriate
permissions.

* The ability to monitor users connected to specific projects.

* The ability to purge log files on the server.

Groups of users can be set up with specific permissions for given projects (or baselines) allowing
them to view or edit projects and sub-components. Projects can also be set as secure or not.
When the user attempts to open a security-enabled project, the permissions are validated by the
server software which resides on the Optimal Trace Enterprise Server. Levels of permissions
dictate the perspective the client has and the level of access permitted. Clients working with
offline projects can change them at will, however, permissions are checked on initiating a merge
to a corresponding repository project.

Getting Help

At Compuware, we strive to make our products and documentation the best in the industry.
Feedback from our customers helps us maintain our quality standards.

Go to http://frontline.compuware.com to access online customer support for Compuware products.
You can read or download documentation, frequently asked questions, and product fixes, or
e-mail your questions or comments. In the Log In section, enter your login ID and password
and click Login. If you are a first-time visitor, click Register to receive your free password to
access FrontLine. After completing the registration form, your login ID and password are
e-mailed to you and your account is activated.

If you need support services, please obtain the following information before calling Compuware's
24-hour product support hotline:

* The name, release (version), and build number of the product. The name and release are on
the covers of the product documentation.
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* Installation information, including installed options, whether the product uses local or network
databases, whether it is installed in the default directories, whether it is a standalone or
network installation, and whether it is a client or server installation.

* Environment information, such as the operating system and release on which the product is
installed, memory, hardware/network specifications, and the names and releases of other
applications that were running.

* The location of the problem in the product software, and the actions taken before the problem
occurred.

* The exact product error message, if any.

* The exact application, licensing, or operating system error messages, if any.

* Your Compuware client, office, or site number, if available.

Compuware Customer Support

Compuware Corporation

One Campus Martius

Detroit, MI 48226-5099

Toll free: 800-538-7822

http://frontline.compuware.com
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CHAPTER 1

System Requirements

System Requirements for Optimal Trace Enterprise

Pentium 4-class processor equivalent or higher

256 MB RAM (minimum), 512 MB or higher (recommended)
175 MB of available hard disk space

Microsoft Windows Server 2003, XP, or Vista

Adobe Reader 5.0 or later for Help files

Software Compatibility

Microsoft Word 2000, 2003, or 2007

Microsoft Project 2000 or 2002

Enterprise Architect 6.5

Citrix Presentation Server 4.0 with service pack 2005.04

Citrix Client 8.0, 9.0, 9.15, or 9.23

NOTE

Note: Optimal Trace does not support Citrix Client 9.20 since there are known issues with
running Java applications.

System Requirements for Optimal Trace Enterprise

Server

Pentium 4-class processor equivalent or higher

512 MB of RAM (minimum), 1 GB (recommended)
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Chapter 1 - System Requirements

250 MB of available hard disk space

Microsoft Windows XP, Vista, Server 2003 (32-bit and 64-bit), or Server 2008 (32-bit and
64-bit)

Oracle 10g Release 2, 11g Release 1 or
Microsoft SQL Server 2005, Microsoft SQL Server 2008 or
MySQL Version 4.1, 5.0

NOTE

There is a known issue with MySQL version 5.0.42, which should be resolved for future
MySQL releases. Optimal Trace Enterprise does not support MySQL 5.0.42 and recommends
using version 5.0.37.

Adobe Reader 5.0 or later for Help files

System Requirements for Optimal Trace Professional

Pentium 4-class processor equivalent or higher

256 MB RAM (minimum), 512 MB or higher (recommended)
150 MB of available hard disk space

Microsoft Windows Server 2003, XP, or Vista

Adobe Reader 5.0 or later for Help files

Software Compatibility

Microsoft Word 2000, 2003, or 2007

Microsoft Project 2000 or 2002

Enterprise Architect 6.5

Citrix Presentation Server 4.0 with service pack 2005.04

Citrix Client 8.0, 9.0, 9.15, or 9.23

NOTE

Note: Optimal Trace does not support Citrix Client 9.20 since there are known issues with
running Java applications.

Prerequisites

If the User Access Control (UAC) feature is enabled, you must ensure that you have elevated
privileges prior to installing Optimal Trace Enterprise and Optimal Trace Professional.
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CHAPTER 2

Installing Optimal Trace

Installing Optimal Trace Enterprise and Professional

Unless specified, these installation procedures apply to both Optimal Trace Enterprise and
Optimal Trace Professional. There are separate instructions for installing the server component
of Optimal Trace Enterprise. For more information, see Installing Optimal Trace Enterprise
Server [p. 12].

NOTE

If using Windows Vista, you must have administrator permissions.

N o ke wDN

10.

11.

Navigate to Optimal Trace on the installation media. Click the version to install. The Open
File dialog box appears.

Click Open. The Installation Wizard appears.

Click Next. The License Agreement screen appears.

Accept the agreement and click Next. The Customer Information screen appears.
Type a name in the User Name field and a company name in the Organization field.
Click Next. The Destination Folder screen appears.

Click Change to choose a destination folder or click Next to accept the default folder. If
changing the destination folder, the Change Current Destination Folder screen appears.
Browse or type a new directory and click OK. The Destination Folder reappears. Click
Next. The Ready to Install the Program screen appears.

Click Install. The Installation Status screen appears.

Click Next after the installation completes. The Installation Complete screen appears.
Click Finish. If you are installing Optimal Trace Enterprise, continue with the following
steps. Otherwise, you are done.

Install the Document Import Tool. For more information, see Optimal Trace Document
Import Tool [p. 13].

Optimal Trace Installation Guide 11



Chapter 2 - Installing Optimal Trace

12. Install the Optimal Trace Enterprise Server. For more information, see Installing Optimal

Trace Enterprise Server [p. 12].

Installing Optimal Trace Enterprise Server

To install Optimal Trace Enterprise Server:

1.

From the installation media, navigate to the optimal Trace Server installation directory.
Double click optimal_Trace_Server_Install.exe.

Follow the instructions by clicking Next. During the install you will be prompted to copy
over permissions settings to the current release. Click Yes if you wish to do so (it is
recommended that you do).

Click Finish to install. The install should complete in a matter of minutes.

Once the installation is complete, click Start>All Programs>Compuware>Optimal Trace
Enterprise>Optimal Trace Server>Optimal Trace Server. Refer to the Optimal Trace
Enterprise Server User Guide for usage and configuration information.

After installing Optimal Trace Enterprise Server, you must create a database in which to store
Optimal Trace remote projects. For more information, see Configuring MySQL [p. 21],
Configuring Microsoft SQL Server [p. 27], and Configuring Oracle [p. 25].

Installing Optimal Trace Silently

A Silent install of Optimal Trace allows you to run the Optimal Trace installer from a command
line and suppress the installer wizard. You must uninstall a previous release of Optimal Trace
prior to performing the following steps.

12

1.
2.

Open a command prompt window.
If a previous release of Optimal Trace is installed, you must uninstall it as follows:
msiexec.exe /x <ProductCode>

The <ProductCode> is a unique identifier for each release of Optimal Trace. The
<ProductCode> for each release is as follows:

* Enterprise: {CD571E64-3D63-41BE-86BD-DDC15F1ADSEC}

* Professional: {22CBCOEF-B1A2-496E-9893-9A6AB67BAACF}

¢ Server: {BD9D540D-66C1-46C5-BED2-9ABCB4CDF389}

* Server (x64): {0D007A48-187A-419B-94C7-BFD70668F31E}

The following example shows how to uninstall the Enterprise edition silently and create a
log:

msiexec.exe /x {CD571E64-3D63-41BE-86BD-DDC15F1AD5EC} /qn /1 *v <log file
nhame>

NOTE

For a complete list of msiexec. exe installation options, type msiexec ? from a command
prompt.
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Chapter 2 - Installing Optimal Trace

3. Install the desired product using one of the following installation commands:

* msiexec.exe -I OptimalTraceEnterprise.msi>
* msiexec.exe -I OptimalTraceServer.msi>

* msiexec.exe -i OptimalTraceProfessional.msi>

Optimal Trace Document Import Tool

Optimal Trace contains a document import tool which enables the user to mark up Microsoft
Word documents and import them into Optimal Trace. This tool uses a plug-in in Microsoft
Word. In order to use this plug-in, a dll file must be registered. This file will be registered
automatically when Optimal Trace is installed. If you are experiencing difficulty running the
document import tool it may be because the plug-in is not registered correctly.

NOTE

If using Windows Vista, you must have administrator permissions.

To register the tool manually:

Shut down Word and Outlook.
Shutdown any Winword.exe processes that may be running using the Task Manager.
Click Start>Run. The Run dialog box appears.

P wNRE

Type cmd in the Open field, and click the [Return] key. The Command Prompt dialog
box appears.

5. At the command prompt change directory to the Optimal Trace installation folder. For
example: cd c:\Program Files\Compuware\Optimal Trace Enterprise.

6. At the command prompt type: regsvr32 OptimalTraceWordDocImport.dll.

Configuring the .lap and .conf Files

IF UAC is enabled, user must configure .lap and .conf files.

If the User Access Control feature is enabled and the user does not have elevated privileges,
the installation will fail to configure several files. If the installation fails, the following files
must be configured according to the edition of Optimal Trace installed. The Optimal Trace
edition is noted next to the files affected.

* Optimal Trace Server.lap (Enterprise Server Edition)

* Optimal Trace Admin Tool.lap (Enterprise & Enterprise Server Editions)
* Optimal Trace Migration Utility.lap (Enterprise Server Edition)

* Optimal Trace Professional.lap (Professional Edition)

* Optimal Trace Enterprise.lap (Enterprise Edition)

* Optimal Trace Command Line Report.lap (Enterprise Edition)

*  Wrapper.conf (Enterprise Server Edition)

Optimal Trace Installation Guide 13
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10.
11.
12.

13.
14.

15.
16.

In Windows Explorer, navigate to the installation directory. For example, the default
installation directory is C:\Program Files\Optimal Trace Enterprise.

Select one of the .lap files to configure and open with a text editor.
Search for the placeholder called DLMLOCPLACEHOLDER.
Replace the placeholder with <COMMONFILES>\Compuware where <COMMONFILES> is

the DLM installation path. For example, the default is C:\Program Files\Common
Files\Compuware.

Search for the placeholder called DLMJARPLACEHOLDER.

Replace the placeholder with <COMMONFILES>\Compuware\DLM40JNI.jar where
<COMMONFILES> is the DLM installation path. For example, the default is C: \Program
Files\Common Files\Compuware\DLM4@JNI.jar.

Repeat steps 3 through 6 for the remaining .lap files.

In Windows Explorer, navigate to the installation directory. For example, the default
installation directory is C:\Program Files\Optimal Trace Server.

Select the Wrapper.conf file.

Open the Wrapper.conf file in a text editor.

Search for the placeholder called SERVICELOGPLACEHOLDER.

Replace the placeholder with <ALLUSERSPROFILE>\Application Data\Compuware\Optimal
Trace Server\<RELEASE_NUM>\service.log. For example, the default is C:\Documents

and Settings\All Users\Application Data\Compuware\Optimal Trace
Server\<RELEASE_NUM>\service.log.

Search for the placeholder called DLMLOCPLACEHOLDER.

Replace the placeholder with <COMMONFILES>\Compuware where <COMMONFILES> is
the DLM installation path. For example, the default is C:\Program Files\Common
Files\Compuware.

Search for the placeholder called DLMJARPLACEHOLDER.

Replace the placeholder with <COMMONFILES>\Compuware\DLM40JNI.jar where

<COMMONFILES> is the DLM installation path. For example, the default is C: \Program
Files\Common Files\Compuware\DLM4@JNI. jar.

Uninstalling Optimal Trace

To uninstall Optimal Trace Enterprise and Professional:

14

1.
2.

Open Add or Remove Programs from the Control Panel.
Select the appropriate product and click Remove.

Uninstalling will leave project files, generated documents and change logs on your hard disk.
This allows you to preserve any previously created project documentation if migrating to a new
version.
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CHAPTER 3
Upgrading Optimal Trace

When upgrading a release of Optimal Trace, the following custom objects will automatically
copy to the new release:

* Custom Project Templates
* Custom Document Profiles
¢ Custom Queries

* Custom Reports

NOTE

If the User Access Control (UAC) feature is enabled, you must have elevated privileges for
these objects to automatically copy. If you do not have appropriate Windows privileges, the
objects will not copy.

The following user settings will not transfer:

* Custom spell check dictionaries

* Export profiles

* General options settings

Upgrading from the release immediately preceding the current release uninstalls the preceding
release. For example, if you upgrade from 5.1 to 5.2, the 5.1 release is uninstalled and the 5.2
release is installed. If you upgrade from a release that is two releases earlier than the current

release, however, the earlier release is not uninstalled. For example, if you upgrade from 5.0 to
5.2, the 5.0 release is not uninstalled. Both releases will be available for use.
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CHAPTER 4
Migrating Projects and Databases

Migrating Projects and Databases Created Prior to 5.0

When migrating local projects or databases created in an Optimal Trace release prior to 5.0,
you must perform an incremental migration. First, you must migrate the projects or databases
to 5.0, and then proceed with the migration from 5.0 to the current release of Optimal Trace.
For more information, see Migrating Remote Projects from 5.0 [p. 17], Migrating Remote
Projects from 5.1 to 5.2 [p. 18], and Migrating Local Projects [p. 18].

About Migrating an Optimal Trace Database

When upgrading to a current release of Optimal Trace, you must also migrate any existing
Optimal Trace databases created prior to the current release. If your database was created two
releases earlier than the current release (for example, 5.0 to 5.2), you must use the Migration
utility. For more information, see Migrating Remote Projects from 5.0 [p. 17]. If your database
was created in the release immediately preceding the current release (for example, 5.1 to 5.2),
you are prompted to migrate the database when you start Optimal Trace Enterprise Server. For
more information, see Migrating Remote Projects from 5.1 to 5.2 [p. 18].

Migrating Remote Projects from 5.0

To migrate remote projects stored in an Optimal Trace 5.0 database to work with the current
release of Optimal Trace, you must use the Migration utility. Prior to migrating your existing
database, you must create a new database in which to migrate data.

NOTE

Depending on the size of your database, it may take several hours to migrate your data from
5.0. Additionally, the database transaction log may grow significantly. Make sure you allocate
enough space for the database transaction log.
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This topic describes how to use the Migration utility to migrate a 5.0 database to work with
the current release of Optimal Trace.

Stop your Optimal Trace server. For more information, see Stopping the Server [p. 19].

Back up your database. For more information, see Backing Up an Optimal Trace Database
[p. 18].

3. Create a new database in which to migrate your data. Click
Start>Programs>Compuware>Optimal Trace Enterprise>Optimal Trace
Server>Optimal Trace Migration Utility. The Optimal Trace Migration Utility appears.

In the Database Host Name box, type the database host name.
Select the database type (MySQL, SQLSERVER, or Oracle) from the Database Type list.
Type the database port number if not using the default port in the Database Port box.

N o ke

Under Source Database, type the name of the database to migrate and specify the user
name and password in the appropriate boxes.

8. Under Destination Database, type the new name of the database and specify the user name
and password in the appropriate boxes.

9. Click Migrate.

The Migration utility runs and migrates remote projects stored in the database to work with
the current release.

Migrating Remote Projects from 5.1 to 5.2

To migrate remote projects stored in an Optimal Trace 5.1 database to work with the current
release of Optimal Trace, perform the following steps:

1. Back up your database. For more information, see Backing Up an Optimal Trace Database
[p. 18].
Install the current release of Optimal Trace Enterprise Server.
Start Optimal Trace Enterprise Server and open your existing Optimal Trace 5.1 database.
A message box appears prompting you to migrate your database.

4. Click Yes to migrate the database.

Migrating Local Projects

When attempting to open an Optimal Trace local project created prior to the current release,
you will receive a message asking you to confirm that you want to migrate your project to the
current release. Click Yes to open the project. When you click Save or you choose File>Save,
the project is migrated to the current release of Optimal Trace.

Backing Up an Optimal Trace Database

18

Before upgrading from a previous release, Compuware recommends Backing up your database.
This is recommended to safeguard your data in the rare case where an error occurs during the
migration process that leaves your data in a half-migrated state.
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Backing up a MySQL Database
To backup a MySQL database:

Open a command prompt.
Change directory to c:\mysql\bin or wherever MySQL is installed.

3. Type mysqldump -q optimaltrace > c:\temp\OptimalTrace-data-backup.sql. You
may need user/password included in the command line for this.

This creates a backup file called optimalTrace-data-backup.sql in the c:\temp\ directory.
You can move this somewhere else for safe keeping.

Backing up an Oracle Database

Creating a backup of the tablespace which contains the Optimal Trace schema is beyond the
scope of this document. Please contact your Oracle Database Administrator or refer to Oracle
documentation. To avoid a potential problem with Oracle's OPEN_CURSORS setting that you
may encounter when migrating, it is best to set this Oracle setting now. To do this, change the
value of OPEN_CURSORS to 20000 in the following files:

* ipit.ora in <oracle_install_dir>\admin\OEMREP\pfile
* init.ora in <oracle_install dir>\admin\Oracle\pfile

* init.ora in <oracle_install_dir>\admin\prod\pfile

And then reboot the machine. For more information on this Oracle issue, see:
http://www.praetoriate.com/oracle_tips_mamt_parameter_file.htm.

Backing up a MS SQL Server 2005/2008 Database
To backup a SQL Server database:

Start Microsoft SQL Server Management Studio.
Navigate to the Optimal Trace database to back up, and then right-click.
A context-sensitive menu appears.

3. Select Tasks>Back Up.
The Back Up Database dialog box appears.

4. Enter the required information, and then click OK.

Stopping the Server

If the server is running from the GUI, click Stop. If the server is running as a windows service,
stop it as follows:

Open the Windows Control Panel and launch Administrative Tools>Services.
Navigate to OptimalTrace.

Right-click and choose Properties from the menu.

Select Stop.

A A

Change the Startup type to Manual.
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CHAPTER 5

Configuring MySQL

This section describes how to configure a MySQL database to work with Optimal Trace
Enterprise Server.

About MySQL

MySQL is a popular open source database. Full details can be found at http://www.mysqgl.com.

Optimal Trace Enterprise does not support MySQL 5.0.42 and recommends using 5.0.37. When
finished downloading, you should have the MySQL installationfile: mysql-5.0.X-win.zip,
where X is the minor version number. For example, mysql-5.0.37-win32.zip.

Installing MySQL

To install MySQL:

1.

AR S L

If running an earlier version of MySQL, shut down the service before upgrading. Type
>NET STOP mysql at a command prompt to shut down the service.

Unzip mysql-5.0.37-win32.zip to a directory. For example, C:\Mysql.
Run setup.exe from the directory. For example, C:\Mysql.
When prompted for installation type, choose Typical.

When finished installing, set up MySQL as a Windows service. For more information, see
Install MySQL as Service [p. 21].

Install MySQL as Service

To install MySQL as a service:

1.

Create a file named my . cnf, which must reside in the root drive where the MySQL
installation has been placed. For example, if you installed to c: \mysql then the my . cnf file
would be located at c:\my.cnf. If you installed to an e: drive, then the cnf file would be
located at: e:\my.cnf.
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2.

Place the following entries into the my. cnf file, or, alternatively, see the note below on
using a copy of the sample MySQL configuration file shipped with Optimal Trace Enterprise
Server.

# The MySQL server

[mysqld] basedir=c:/mysql
datadir=c:/mysqgl/data

set-variable = max_allowed_packet=100M

innodb_data file path = ib:200M:autoextend
innodb_data_home_dir=c:/mysqgl/ibdata
set-variable = innodb_mirrored_log_groups=1
innodb_log_group_home_dir=c:/mysqgl/iblogs
set-variable = innodb_log_files_in_group=3
set-variable innodb_log file size=306M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
innodb_log_arch_dir=c:/mysqgl/iblogs
innodb_log_archive=0
set-variable=innodb_buffer_pool_size=80M
set-variable=innodb_additional_mem_pool size=16M
set-variable=innodb_file_io_threads=4

Optimal Trace Enterprise ships a sample MySQL configuration file, called my.cnf. txt,
which can be found after you install Optimal Trace Server, in the Scripts folder in your
Optimal Trace Server installation folder. You can copy this file to the root drive and rename
it to my . cnf. To edit a file’s extension string using Windows Explorer:

* In Windows, choose Tools>Folder Options>View.
* Clear the Hide file extensions for known file types box.

* Rename the file to remove . txt from the file name.

For the file name example above (my.cnf. txt), Windows may hide the string .cnf and
the file name may appear simply as my .. MySQL also ships with a sample . cnf file called:
my -example.cnf. This file contains many other additional parameters that can be configured
for MySQL. For more information, refer to http://dev.mysql.com/doc/.

If the installed version of MySQL requires transactional tables to be manually enabled then
you must create two sub-directories in the MySQL install directory. Name the newly created
directories ibdata and iblogs. Your Mysql directory structure should now look something
like the following:

= i) Mysqal
E I bench
I bin
I+ :;:jldatﬂ
® [J) Docs
[+ ) examples
I ibdata
I iblogs
I indude
E I lib
i) scripts
[ [3) share
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To complete the procedure for installing MySQL as a service, open a command window,
change the directory to your MySQL installation folder (c:\mysgl\bin), and then run:
mysqld-max-nt --install.mysqld-max is used because it provides support for symbolic
links, BDB tables and InnoDB tables. This allows the use of transactional tables, which
are used by Optimal Trace Enterprise Server.

Now that MySQL is installed as a service it can be started and stopped, from anywhere on
the command screen, using the NET command as follows: NET START mysql. Upon a
successful start, a message confirming the MySQL service was started successfully appears
on the screen. NET STOP mysql MySQL may take 5 minutes to stop. When it successfully
stops, a message confirming the MySQL service was stopped appears. MySQL can also
be started from the Services directory by choosing Start>Settings>Control
Panel>Administrative Tools>Services>MySQL.

Create the Database and Server tables

1.

Move to location where you have installed Optimal Trace Enterprise Server and copy
mysql OptimalTrace_install.sql fromthe <INSTALL DIR>\scripts directory into your
<MySQL install directory>\scripts.

Type the following line to create the database tables:

C:\MySql\bin>mysql -uroot < ..\scripts\mysql_Optimal Trace_install.sql
Upon successful completion there will be no response, only the prompt C:\Mysql\bin.
By default the root user has no password so the above command should work without
modification. If the root user’s password has been modified then you will get the following
error message: ERROR 1044 at line 1: Access denied for user: '@localhost' to
database 'optimaltrace'

If this is the case, an additional password argument must be supplied after the user name.
For example, C:\Mysql\bin>mysql -uroot -ppassword < ..\scripts\mysgl Optimal
Trace_install.sql Younow have a user with SELECT, INSERT, UPDATE and DELETE
privileges on the 'optimaltrace' database with username ‘optimaltrace’ and password
‘otpassword’.

Uninstalling MySQL

To uninstall MySQL.:

1.

Click Start>Settings>Control Panel>Add/Remove Programs and click on the version
of MySQL to remove.

Click Change/Remove and an Install Anywhere Uninstaller screen will appear.

Click Uninstall. This will completely remove all components installed. It will not remove
files and folders created after the installation.

Optimal Trace Installation Guide 23



Chapter 5 - Configuring MySQL

24 Optimal Trace Installation Guide



CHAPTER 6
Configuring Oracle

This section describes how to configure an Oracle database to work with Optimal Trace Enterprise
Server.

Oracle Prerequisites

* Oracle database administration experience.

* The Oracle software is installed. This includes setting up various environment variables
unique to your operating system and establishing the directory structure for software and
database files.

* You need to have the operating system privileges associated with a fully operational database
administrator. You must be specially authenticated by your operating system or through a
password file, allowing you to start up and shut down an instance before the database is
created or opened.

* Ensure that there is sufficient memory available to start the Oracle instance, and that there
is sufficient disk storage space for the planned database on server.

Configuring an Oracle Database

You can either create a new Oracle database or reuse an existing Oracle database. For instructions
on creating a new Oracle database, refer to your Oracle system administrator or to Oracle
documentation.

To configure an existing Oracle database to use with Optimal Trace Enterprise Server, change
the following settings in the Character Set tab of the Wizard:

* Select Use Unicode (AL32UTFR) checkbox.

* Select UTF8-Unicode 3.0 OTF8 Universal Character Set from the National Character Set
list.

Optimal Trace Enterprise Server provides installation scripts to create tablespaces, tables, and
users. Copy the scripts from the following location of the installation directory
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(<INSTALL_DIR>\Program Files\Compuware\Optimal Trace\Optimal Trace Server
Edition\scripts\\oracle_Optimal Trace_install.sql) to the Oracle default location
(ORACLE_HOME\database).

To configue Optimal Trace database objects, start SQL*Plus and connect to your Oracle instance
AS SYSDBA:

SQL> CONNECT SYS/password AS SYSDBA

Create a tablespace, tables, indexes, sequences and a user. From SQL*Plus command line, type
the following:

SQL> @"<INSTALL_DIR>\scripts\oracle Optimal Trace_install.sql"

This script will create a table space for your Optimal Trace Enterprise Server called

optimaltrace, as well as user optimaltrace with password otpassword. After the initial
configuration, you can change this username and password.
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Configuring Microsoft SQL Server

This section describes how to configure a SQL Server database to work with Optimal Trace
Enterprise Server.

Prerequisites

Microsoft SQL Server software is installed. For installation instructions, refer to the Microsoft
SQL Server installation guide.

Documentation, support, and downloads for SQL Server are available from the following
location: www.microsoft.com/sql/ .

You need to have the privileges associated with a fully operational database administrator
and be allowed to start up and shut down an instance of Microsoft SQL Server before the
database is created or opened.

Ensure that there is sufficient memory available to start the Microsoft SQL Server instance,
and that there is sufficient disk storage space for the planned database on server.

Optimal Trace Enterprise Server provides installation scripts for creating a SQL Server database
to use with Optimal Trace Enterprise Server. For more information, see Microsoft SQL Server
2005/2008 Database [p. 27].

Microsoft SQL Server 2005/2008 Database

Perform the following steps to create a SQL Server 2005 or 2008 database to use with Optimal
Trace Enterprise Server.

1.
2.

Start Microsoft SQL Server Management Studio.

Click File>Open>File, and browse to <INSTALL_DIR>\Program Files\Compuware\Optimal
Trace\Optimal Trace Server Edition\scripts.

Select mssqlserver_optimaltrace_install.sql, and then click Open.

Select the Execute option from the toolbar. This will invoke all queries within the script.
For example, the create database, tables and user/privileges queries.
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Invoking this script creates the database optimaltrace and all the required tables, as well as
user optimaltrace with password otpassword. You can change this username and password
after the database is created. After the script completes, close the opened script file and exit the
Management Studio.

Removing a SQL Server 2005/2008 Database

1. Start Microsoft SQL Server Management Studio.

2. Inthe Object Explorer, browse to MS SQL Server\Database, and then select the database
to remove.

*  Select optimaltrace to remove an Optimal Trace 5.1 or later database.

*  Select catalyze3 to remove an Optimal Trace database created prior to 5.1.

3. Right-click the database to remove, and then select Delete. This will remove the database.

4. Toremove the created user, browse to MS SQL Server\Security\Logins, and then select
the created user.

*  Select optimaltrace to remove the created user for an Optimal Trace 5.1 or later
database.

*  Select catalyze3 to remove the created user of an Optimal Trace database created prior
to 5.1.

Microsoft SQL Server Notes
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Using the following command, you can change the default database settings of the
mssqlserver_Optimal Trace_install.sql script.

Create database [optimaltrace] ON (NAME = N'optimaltrace',
FILENAME = N'<INSTALL_DIR>\Program Files\Microsoft SQL Server\MSSQL\data\optimaltrace.mdf'

4
SIZE = 100, FILEGROWTH = 10%) LOG ON (NAME = N'optimaltrace_log',
FILENAME = N'<INSTALL_DIR>\Program Files\Microsoft SQL
Server\MSSQL\data\optimaltrace_log.LDF' ,
SIZE = 30, FILEGROWTH = 10%)
To use the second command, comment out the first, and then uncomment the second. Both are
given in the script with the second commented out. The administrator can change the specified

values given as required.

* A login called 'optimaltrace' is created and given a 'db_owner' role on the database.
exec sp_addlogin 'optimaltrace', 'otpassword' ,'optimaltrace'
exec sp_grantdbaccess 'optimaltrace'
exec sp_addrolemember 'db_owner', ‘'optimaltrace'

The administrator can amend this, but read/write access to the database is required.
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Running Optimal Trace

This section describes how to run Optimal Trace Enterprise. To run Optimal Trace Enterprise
Server, refer to the Optimal Trace Enterprise Server User Guide.

Connecting to Optimal Trace Enterprise Server

Before using Optimal Trace Enterprise to create and edit repository based projects, you must
configure it to connect to Optimal Trace Enterprise Server. It is possible to load Optimal Trace
offline (file based) projects into Optimal Trace Enterprise without having the remote connection
set up. Additionally, local file-based projects can be created from scratch and edited without
setting up the remote connection.

* Click Start>Programs>Compuware>Optimal Trace Enterprise>Optimal Trace
Server>Optimal Trace Server>.

* Enter your server settings.
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Figure 1. General Options — Server Settings screen
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Table 1. General Options — Server Settings screen

Item

Description

Host Name for Server

Enter the host name for the repository server. On a standard
network this will be the machine name where Optimal Trace
Enterprise Server is running. If your repository server is
running on your local computer, you can type ‘localhost’ in
place of the computer’s network name. Alternatively, type
the IP address of the server.

Remote Port for Server

Enter the port number that the repository server is running
on. Ensure that this number matches the setting on the
Optimal Trace server. By default, both the server and client
side settings are set to 5456.

Polling Interval

This is the time setting that controls how often the client
queries the server for updates. You can adjust this upwards
if you wish to have less frequent polling from client to server.

If you want to test the connection to the server hit the Test Connection button. This will attempt
a connection between the client and server using the settings specified. If there is any issue with
the connection, a detailed result screen is shown. Copy and paste the contents of this screen and
send it to your Optimal Trace administrator or network administrator for further information.
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A given client can be set to point at a different server by adjusting the server setting in the

Options screen.

User Support in Optimal Trace Enterprise

Optimal Trace Enterprise allows several users to work on the same Project simultaneously.

When other users edit or add Requirements, Actors or other Project artifacts, the changes will
appear dynamically on your screen. The Optimal Trace Enterprise Server software monitors all
currently connected clients and ensures that all project changes saved to the repository are

broadcast simultaneously to all users. When you are editing an artifact, Optimal Trace Enterprise
ensures that nobody else can edit that artifact or the artifacts upon which it depends, by locking
them. People are free however to edit any Project artifacts that are not directly affected by your

edits.

Licensing

Table 2. Licensing Options

This table describes licensing options for both Optimal Trace Enterprise and Optimal Trace Professional.

Option

Description

Evaluate Optimal Trace

Optimal Trace can be evaluated for a specific period of time without
a license key. When you first run the product, you do not require a
license. The evaluation period is calculated from the time of first
usage, in other words from the initial running.

Once this period of time elapses you must either purchase a full license
or else apply for an extension key.

License the application fully or
use an extended evaluation
license key

Aside from the initial evaluation period as outlined in the previous
section, Optimal Trace requires a license to run. It ships with a License
Administration utility called the LAU (License Administration Utility).
For full details on how to license Optimal Trace, please run the LAU
and refer to the LAU help file under the Help>Index.

Upgrading from a previous
release

If upgrading from a previous release of Optimal Trace, you will need
to install a new license.
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